EC Living TANA SL-1 , Apple Airplay

Hi, unfortunately Roon has issues to detect my EC Living TANA SL-1 as Airplay device. Another Airplay device appears. However, sometimes I like to stream to the TANA SL-1. If this will not work out I would cancel Roon. Any idea?
Thansk for help, Chris

You might verify that they are on the same network subnet as your Roon Core.

Hi @Christoph_Schmid ----- Thank you for the report and sharing your feedback with us. Both are appreciated!

Moving forward, I agree with @Rugby’s suggestion in regard to confirming that the SL-1 is on the same subnet as the device hosting your core. Furthermore, just to confirm, no issues when using the SL-1 outside of Roon via another application on the core machine?


Hi, Thanks for the replays. I can confirm both. It is on the same subnet and if I start ITunes from the same computer it detects the speaker immediately. Also my iPad detects the SL-1. Any other idea?

Thanks for taking the time to answer mine/our questions, @Christoph_Schmid!

Moving froward, would it be possible for you to test with unit (temporarily of course) hardwired directly to your router via ethernet to see if the application can recognize the unit not using Airplay?


I tried it. Also hardwired the speaker does not get recognized.

Thanks for getting back to me @Christoph_Schmid and my apologies for the slow response.

Moving forward, I would like to have our techs take a closer look into this behavior you are experiencing with the Tana SL-1, so I have went ahead and enabled diagnostics on your account. What this action will do is generate a report containing a set of your logs that will be automatically uploaded to our servers when your Roon core comes online next.

Furthermore, I would like to have a complete understanding of your current setup for my report to our tech team. With this in mind may I very kindly ask you to provide brief but accurate description of your current setup using this link as a guide.

Lastly, I want to be up front there may be a chance that we will not be able to do anything until we try to get one of these units (i.e the TANA SL-1) in house to test with. Obviously this depends on if there is anything noteworthy in the logs, etc.


Thanks. I will try to describe my settings as soon as I have a bit more time. Meanwhile I also moved the core from my windows pc to my Mac notebook. Only to exclude that it has something to do with the settings of the core unit. However, the result is the same. The TANA SL-1 are not recognized. Other apps on the Mac can use airplay perfectly with the TANA SL-1.

1 Like

Thanks for touching base with me @Christoph_Schmid, I will be on the look out for your follow up!


what version of Roon you are running:
roon version 1.3 (build 269) stable (64bit)

What operating system you are running:
macOS High Sierra and Windows 10, Version 1709 (I have tried it on both, same problem)

Macbook 2017, 1,2 Ghz Intel Core m3, 8GB RAM
DELL XPS 15 9560 Intel i7-7700HQ 2.8 Ghz, 16 GB RAM

Describe where your music is stored:
Hard disk and Auralic mini

Let us know your collection size (approximate number of tracks):
approx. 6000

Used wifi router:
Google Wifi

Do you need any other information?

Thanks for getting back to me @Christoph_Schmid, very appreciated!

Just to make sure I have everything I need, can you please confirm that the mentioned router (“Google WiFi”) is the only networking hardware in your setup currently. No other routers acting as access points, switches, repeaters, extenders, etc.

If you DO have additional devices, please provide the make/model of these units and where they “fit in” to the chain of communication.


The Google WiFI is connected to a fritz box. However the fritz box acts as broadband modem only. All devices are connected to the Google WiFi. Roon can also find airplay devices in this network even my Sonos players. Only the TANA SL-1 cannot be found. On the other hand the TANA SL-1 can be used as airplay device from all computers and devices in the network. Therefore, I don’t think it is because of the fritz box.

Thanks for the follow up @Christoph_Schmid, appreciated!

My last post wasn’t meant to imply that this is due to your hardware, but more so to make sure I had a complete understanding of your setup for my report :wink:

As mentioned I will be discussing this with our tech team to see if they can provide any insight into this behavior that you are experiencing with the TANA SL-1. Once I have some feedback from the team I will be sure to update you in a timely manor.


Hi @Christoph_Schmid ---- Thank you for your patience while I have been discussing this issue with the team.

This behavior you are experiencing is most likely related to how Airplay is implemented in this device, and it’s going to be hard for us to make progress on this without being able to look at it directly.

Moving forward, we are going to try to get one of these devices (Tana SL-1) in house for testing in our QA lab to better understand the cause of this behavior. Be advised that this process may take some time, so I will be sure to keep you updated on our progress, when and if the device arrives.


@Eric, was anything updated in this respect lately? Because I have just started evaluating roon and it detects my EC Tana SL-1 over Airplay just nicely. I am using Roon 1.4 on Mac OS X 10.13.3.

Thanks for sharing your experience with us @Dejan_Beznec, appreciated!

We are still waiting on the gear to be provided to us for testing but in regard to your question, nothing has been changed on our end.