Editing Internet radio is a little buggy [Resolved]

I’ve spent a little time this afternoon cleaning up Internet radio in Roon. After the 1.3 upgrade (and possibly before; I hadn’t used it in a while) I found that there were some stations that wouldn’t play.

In editing, I’ve run into a few little bugs, or so it seems to me.

One problem I have is that sometimes a station is selected (i.e. for editing) but can’t be unselected. I can click on the little x in the circle again and again and nothing happens. Other controls (i.e. edit) are grayed out. Since other controls (like the back arrow) are hidden in this state, I’m left with no choice but to close Roon and restart.

There’s also a radio station I couldn’t get to work (France Musique jazz; is it because I’m in the U.S.?), so I tried to delete it. At first nothing happened–the station was still there–and then Roon crashed. When I restarted, the station was gone.

One other comment: I’m using the file browser to add art to the stations I add. It’s quite primitive and not so well behaved. For example, I can’t reorder files by date added. If I download an image to the directory where I keep my music images (in preparation for adding it to an Internet radio stations) the new file doesn’t show up unless I refresh. And if I close editing on one station and then open another, then access the file browser, I’m already drilled down to that same directory. That would be fine–even good–except for what I said a moment ago: If I’ve just downloaded a suitable new image, in preparation for adding it to a radio station, the new image doesn’t show up. So then I have to refresh again. Not a big deal, but not ideal.

I’m running RoonServer on a NUC, headless, controlling via a MacBook pro operating as remote. Latest OSX, Roon build 196.


Hi @Jim_Austin ---- Thank you for the report and my apologies for the slow response. We have tried replicating this behavior on our end and are having trouble doing so. Are there anymore steps you can provide to help aide in our attempt to reproduce this behavior? No detail is too small.

Furthermore, can you please provide me with a URL to the radio station mentioned in your report?


As soon as I saw this, I popped over to Roon to see if I could reproduce. Roon had been open for a while–NOT freshly loaded. I chose “Internet Radio” from the drop-down, chose a station at random, and hit CTRL-click to edit. Here’s what I saw when I did that:

Several controls–like the “Sorted by” drop-down–are responsive. But when I click on the x in the circle to close “edit”, nothing happens. So there’s no way to get out of this except to close the program. So I closed and restarted and was pleased to see that my radio stations are still there:

Now everything is working as it should. I can edit a station, and successfully unselect via the x in the circle. OK, so now I chose another station, Ctrl-click to edit, typed “test” into the description field, saved. All is OK, so then I did Ctrol-click again to open up the same station to remove that added text:

You’ll notice now that the “Edit” button is grayed out. Again, I cannot unselect the station by clicking the x in the circle. WFMU seems permanently selected; if I click on another station (simple click; no Ctrl), it too is selected, and the upper-left text says “2 Selected” (or some other number selected). Interestingly, if I click on the already-selected station, it is selected again. Here, I’ve clicked on WFMU–no other stations are selected. Note the text upper left:

So WFMU is counted twice. Again, the only way out of this is to close Roon.

I think I mentioned this, but I’m running RoonServer on a headless NUC (6th-gen i3), but I’m doing this on my MacBook Pro (late-2015) running the latest Roon and the latest OS X.

I thought I might add one detail. After posting this, I tried just closing the Roon window rather than closing Roon. Opened up a new window and the problem had NOT gone away. Still stuck on the last screen above. Only way out appears to be closing and restarting the program.

I have the problem of having to close the Roon App on iPad Pro before I could play an internet radio station even after the version 200 update.
You click play on Pawmasher and nothing happens. Restart app and all is well.

I have noticed the same problems. I have not checked if latest version 200 fix this. The release notes said something about radio being fixed.

However I’m not able to play radio at all. I’ve added some Norwegian stations by coping links from Tunein webpage.

Before 1.3, my radio was working.

Are any one here able to play radio ?
Link or name to a working station I can test. ?

Yes I can play Radio, BBC streams anyway but if I wish to change station I have to restart the App first.
Defiantly a bug here.
iPad Pro, QNAP TVS 471 i3 Meridian MS 200

Thanks. Very strange now suddenly radio works.

Yes you are right about a minor error in adding Station.
Just added http://tunein.com/radio/BBC-Radio-6-Music-s44491/
Does not show up. Have to kill the app on my iPad.
Then the Station shows up in the list.

I hope Roon can make a similar user interface for radio as LMS, and probably others as well, where you can browse directly stations either by contry and your area, or type of music.

Hi everyone - Thank you for all of your feedback and sharing your observations with us. We are currently looking into this issue and are still trying to reproduce this behavior consistently. I will report back with our findings once testing has been completed. We appreciate your patience.


Thanks, @Jim_Austin, for forcing me to notice that we can give internet radio streams pictures - it was right there in the station-add dialog, but I’d been ignoring it. Things are much more visual here now!


@Jeffrey_Moore, happy to help, however inadvertently. I appreciate the acknowledgment.


Hi All — I wanted to check in here and see if any new observations or progress has been made? I know some fixes were released and want to see if the experience has been the same. Looking forward to your feedback!


1 Like

I noticed that there was a new built ready for download. So, before downloading it, I did what I did before, and easily reproduced the symptoms. So then I downloaded the new build. Then I went through the same steps.

I’ll play around with it some more, but preliminary indications are that you fixed it.


1 Like

It has been ok for long time now :grinning:

1 Like