Endpoint Disconnected Randomly

Roon Core Machine

Ubuntu Linux VM, 8GB RAM, 4vCPU

Networking Gear & Setup Details

Everything hard wired 1Gbps Ethernet, Cisco Catalyst switches

Connected Audio Devices

Sonore UltraRendu USB to McIntosh d1100 DAC

Number of Tracks in Library

22,610 tracks

Description of Issue

Intermittently, my DAC seems to lose connection to my Sonore UltraRendu. Music stops playing. Some combination of restarting the DAC and UltraRendu, sometimes multiple times fixes it. But, the problem comes back.

RoonServer logs while it was happening below.

It seems fairly obvious that either a connection was lost between the core and the UltraRendu, or the USB connection to the DAC was lost. I am trying to narrow down where the problem is in my chain, because it’s becoming quite annoying. I will be happily enjoying an album and boom…totally kills the mood.

07/06 00:06:54 Trace: [McIntosh d1100] [Lossless, 16/44 ALAC => 16/44] [100% buf] [PLAYING @ 2:41/4:00] Don’t Tread on Me - Metallica
07/06 00:06:59 Trace: [McIntosh d1100] [Lossless, 16/44 ALAC => 16/44] [100% buf] [PLAYING @ 2:46/4:00] Don’t Tread on Me - Metallica
07/06 00:07:04 Trace: [McIntosh d1100] [Lossless, 16/44 ALAC => 16/44] [100% buf] [PLAYING @ 2:51/4:00] Don’t Tread on Me - Metallica
07/06 00:07:07 Info: [stats] 23356mb Virtual, 1312mb Physical, 423mb Managed, 381 Handles, 82 Threads
07/06 00:07:09 Trace: [Sonore ultraRendu @] [raatclient] GOT [27] {“status”:“Lost”,“reason”:{“reason”:“device_not_available”}}
07/06 00:07:09 Trace: [McIntosh d1100] [zoneplayer/raat] Got ‘lost’ response
07/06 00:07:09 Trace: [McIntosh d1100] [zoneplayer/raat] Endpoint Sonore ultraRendu State Changed: Playing => Idle
07/06 00:07:09 Trace: [McIntosh d1100] [zoneplayer/raat] lost endpoint. stopping stream
07/06 00:07:09 Info: [audio/env] [zoneplayer → stream] All streams were disposed
07/06 00:07:09 Info: [audio/env] [zoneplayer → stream → endpoint] All streams were disposed
07/06 00:07:09 Debug: [raat/tcpaudiosource] disconnecting
07/06 00:07:09 Warn: [zone McIntosh d1100] Track Stopped Due to LostEndpoint

Have you tried giving each device a fixed address in your router? Possibly the address is being reset and other devices lose sight of it

Power cycle the DAC and reconnect the USB cable.

Thanks, but the device already gets a DHCP reserved IP that is never used by another device. Also, when it happens, the UltraRendu is pingable, so I don’t think it is an IP reachability issue.

Power cycle the DAC and reconnect the USB cable

That usually works, but I would like to solve the issue of it cutting out in the middle of a listening session. This just solves the issue short term.

Have you tried a different DAC for a bit as a test, to make sure it is not the McIntosh USB input acting flakey.

I would also consider trying a different USB cable. If you’re using an “audiophile” cable, try swapping it out with a bog-standard normal USB cable.

I had something similar a while back between an ultraRendu and a Chord TT2. It turned out to be the LPS 1.2 powering the uRendu. I swapped in a Farad I had in my “library” of spares.

Thanks. How did you narrow it to the LPS? I have the same one. What exactly were your symptoms?

It doesn’t seem to lose power because I can still ping it after the abrupt disconnect

I was losing my endpoint sporadically. First I did the normal troubleshooting:

Rebooting Core
Power cycling the TT2, ultraRendu, LPS1.2, and switch
Replacing the USB cable from the uRendu to the TT2
Changing ports on switch
Replacing Ethernet cable from switch to uRendu

Then I moved the uRendu to another system that also had a uRendu and the problem did not move… The second system also had a LPS 1.2. I moved the original LPS 1.2 to the second location and within 3 hours or so, the problems started to occur.

Hey @joey_corleone,

Ben with the support team here, it’s great to see you on the community again! I’m sorry to hear you’re having issues with your endpoints disconnecting. Since a few days have passed, I wanted to check in and see if you were still running into this issue?

And in the meantime, I always suggest temporarily removing any switches from your setup chain as a test.

We’ll be monitoring this thread for your reply :+1:

Hey Vincent, thanks very much! With your failing LPS, did it always still indicate everything was OK when the problem occurred (green LED)?

Hey Ben, I unhooked the UltraRendu and LPS 1.2, then reseated all the cables and positioned them back facing me so I can monitor the LEDs.

I have still had to do the DAC dance where I power cycle the DAC and UltraRendu to get everything initially running sometimes, but no mid session dropouts yet since the move.

I have had an album looping in Roon for days with no dropouts. But, I have been here before, and it seems to crop up eventually. I am continuing to do testing and will report back if something changes.


The LED remained lit.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.