Endpoint only visible through network switch

Roon Core Machine

Macbook Air M1

Networking Gear & Setup Details

Corporate network with all devices connected by ethernet.

Connected Audio Devices

Tried with Bricasti M3 streamer and Holo Audio RED streamer, both connected by ethernet.

Number of Tracks in Library

3,000 tracks

Description of Issue

I am struggling to understand a networking issue I’m having on my corporate network.

My Roon core is my laptop and I’ve tried a Bricasti M3 and Holo RED streamer as endpoints. All are connected by ethernet into the network.

Basically, Roon only sees the streamer if both the laptop and the streamer are connected into a switch and then into the same ethernet outlet. If I connect them to separate outlets in the same room, Roon can’t see the streamer.

I don’t have the same issue with, for example, a network printer connected to a different ethernet port from the laptop.

With the Holo RED, I can navigate to the local page for the device (red.local) - although I can’t navigate directly using the IP address that appears to be assigned when I have both laptop and streamer connected through the switch. When I look at the IP address of the streamer in Roon when both laptop and streamer are connected to the switch, I see both devices on the same subnetwork (ie xx.x.xx is the same for both).

Grateful for any ideas! Worst case I can use a switch but would prefer not to run a cable across the room.

You may need talk your corporate network admin. Such outlets are connected to switches that can be configured very specific (VLAN, MAC filtering, …). Although the admin may not like what you are doing, you even might violate the company’s IT policies. I am wondering that you are allowed to install software (Roon) at all if that’s a corporate owned device. Depends.

Thanks for your reply. It’s a bit of an odd arrangement - it’s my own device and my own office with my own fit out which I effectively lease from the building owner, but the building network is centrally operated and I pay a fee for access to it and the associated infrastructure. You’re probably right that I will need to deal with the network operator but was hoping there might have been something I could do myself!

I was a little bit in your shoes. The building network centrally operated. I do not understand any of the DHCP vs IPs vs multiple networks. I just wanted internet and my own network. I had to speak with the IT and they fixed my own router (lasted 1 month, I hope for you is quicker). I do not have any idea how it works but now I have my small network with internet

If you contact them tell them the outlet IDs (labels on the network outlets if present) and that you need these in the same VLAN (and/or subnet) with DHCP enabled.

Printers tend to use mDNS to advertise and work across subnets, endpoints for Roon will use UDP broadcasts that are limited to the local subnet they are on. So it likely the other Ethernet ports are a different subnet and this is why they don’t work with endpoints on them.

Thanks all. I will raise that with the building network people and see what they can do.


If you really need to understand what’s going on, look up udp-proxy-2020. Aaron Turner had done a lot of work on how to get udp packets to cross vlans, but you won’t be able to do that if you don’t manage the network. So my guess is that it is “get them on the same vlan” or switch for you.

Hey @dankef,

Ben from the support team here, I wanted to check in to see how things worked out with your network situation?

It certainly limits our ability to provide support here, but I did want to see if you were able to get things sorted out!

Thanks :+1:

Hi Ben - thanks for checking. I wasn’t able to get it to work via the network (i.e. with both my laptop and streamer connected into the network separately), but I have gotten it to work with either the laptop and streamer connected into the network via a ‘dumb’ switch or with the streamer connected directly to the laptop via ethernet. It seems to be an issue with 802.1x authentication. But at least I can use it now, even if the setup is not ideal!


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.