Endpoints Disappear

I’ve seen others with this issue, but not on a Mac and not having all endpoints disappear.

Two days ago, I could play, via Roon, Tidal music thru my Cambridge Audio CVN v.2 endpoint. And my Yamaha receiver was another endpoint but I didn’t use it two days ago.

Today, I have no endpoints accept System Output which is my MacBookPro. The CVN input control shows Roon. But the CVN is invisible to Roon itself. I changed nothing in two days.

Rebooting, connecting, and reconnecting Ethernet cables, ensuring firewall is not blocking Roon (although I didn’t change it), etc. Nothing works to restore any endpoint except my MacBookPro which is also the Core and where all my music is stored.


BTW, I was just about to order a Nucleus to get Roon off my Mac but now not sure if endpoints just disappear.

Sincerely, Mike Davis

Hi @Michael_Davis,

How is the MacBook Pro connected to the network? If it’s connected via WiFi, can you try a temporary Ethernet connection and see if that helps?

Are you able to see these devices from the Mac outside of Roon?

Hi Dylan,

The Canbridge Audio end point shows up on my network in other applications. I need an adaptor to connect my Mac to ethernet cable and I will have that later today or early tomorrow.

Best regards,


1 Like

Hello @Michael_Davis,

Connecting via Ethernet is definitely a good troubleshooting step, so do let us know how this goes!

Also, what if your network setup like, can you provide some details regarding this including model/manufacturer of your router and any additional networking gear?

Have you recently updated any firmware on the router?

I connected my Mac directly with ethernet cable to the modem. Cambridge Audio network streamer still does not show up in Roon. However, I the streamer itself shows it is in the mode of receiving signals from Room and the connection to my LAN is okay. The Cambridge Audio device is also connected directly into the modem.

The modem is from my IP and was just installed three weeks ago so I assume it is up to date. It is an ARRIS Touchstone TG2472. Nothing has changed on it from when Roon was working wonderfully with all my end poiints until Roon stopped recognizing any of them.

Back in the old days, many application problems were solved by deleting the program and reinstalling it Should I try that with Roon?

If you uninstall be careful not to delete your database , it will take a while to rebuild. If I remember rightly there is a check box set to avoid it in the uninstall dialog.

Also backup first !!!

Have you rebooted the core, cold started the network gear etc, that usually fixes stuff

Hi @Michael_Davis,

Yes, if you want to give this a try, you certainly can.
The best way to reinstall Roon is as follows:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Try the fresh database for a day or two to see if issue still occurs
  • Restore from backup made in step 1

This test also allows us to take the previous database out of the equation, so if the issues start re-occurring only following the restore, please do let me know as that is a valuable data point to have.

Thanks, but this will have two weeks. That is how long Apple will take to replace the battery in the Mac that is my core. It is a brick until that happens. Meanwhile, last night Roon unexpectedly recognized another end point. That is a one hundred percent increase in recognized end points. Too bad my battery died so I can’t see if any other end points appeared this morning,

Hi @Michael_Davis,

No worries, whenever you are ready to pick this back up, just let me know!
I’ll leave the thread open for you.

It fixed itself. Only two things changed since the problem appeared. First, my Apple that contains the Core was fixed. Apple’s tech fixed it without affecting any programs or data on my laptop. Second, I installed a new NAS in my network. Oh, and I sacrificed a burned pot roast to the god of LANs.
Now Roon recognized all endpoints. You are welcome to close this action item. Hopefully, it will not reappear so I don’t have to burn any more pot roasts.

1 Like

Hi @Michael_Davis,

Thanks for letting us know that the issue is resolved after the Core was repaired by Apple!
It sounds like the issue is resolved, but if you run into any other difficulties, please just let us know!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.