Endpoints updated with new Roon update not selectable for audio playback [Ticket in]

Roon Core Machine

Windows 10, AMD FX-8320 8-core, 24GB Ram

Networking Gear & Setup Details

Gigabit switch routing throughout. Core to switch to Roon Application (computer connected to same switch as Core)

Connected Audio Devices

Not related to audio device, cannot find album through Roon iOS app or Roon Desktop app

Number of Tracks in Library


Description of Issue

Updated Roon Core first, next iOS followed by Windows 10 Roon application. After update, iOS phone and computer do not show up as selectable audio playback devices (iPhone 8 and Windows 10 Machine, all I have done so far). I have tried to disable and reenable, reboot and reinstall updated applications.

All endpoints that did not require a software update (like Sonos) are selectable and can play music, while all endpoints requiring the software update, despite showing enabled in the settings menu, are absent from selection for audio device playback. There is no way to have audio playback through these endpoints.

A smaller issue in addition, despite all the reinstallations the Roon desktop icon is now just a plain white file, no Roon logo.

Most Recent Edit - By the time I finished writing this post the workaround to get any remote or endpoint that required the Roon Update has disappeared from selection. I currently can only send music to items that did not require a software update.**

Ok, so just a follow up for anyone else who may be having this issue.

Roon Icon: Reinstalled Roon Server application and it then appeared on my windows desktop endpoint.

Audio Devices:

Saw this as a suggestion elsewhere. It work in a limited capacity for now and is not ideal at all when adding new endpoints.

  1. Disable all audio devices. If you want your phone or remote to work, you need to disable from the application.
  2. Once all are disabled, exit remote application.
  3. Exit Roon Server application.
  4. Restart Roon Sever Application
  5. On remote device, enable all devices again.

This works except for two issues.

  1. Roon Remotes that are not showing as a device will not be able to work as a selectable endpoint. For example: I did this from my iPhone, which will not show my iPad as a selectable device (as it has to be done from the remote). Therefore, once I do all of this I cannot get the iPad be selectable to itself when trying to play music from the iPad, or my windows remote endpoints. I am only able to get one roon remote device to play music through this workaround. So if I want music through my iPhone that means no music from my desktop endpoint. If I want to listen to music from my desktop, no music from my iPhone.

  2. If you try to update another endpoint it will not be selectable as an audio source until you repeat the entire process above again. There is no adding one by one, it has to be done all at once through the steps above. Not ideal, but will at least allow music to be listened to until a fix is provided.

Found one work around that seems to be working for now that allows me to use my phone and computer for audio playback. Someone mentioned a limit on Sonos devices (7), as I started to remove devices to get under the 7 number, my other endpoints started to show up.

However, I cannot have more than 7 active Sonos devices. If I try to enable them they do not show up so something is still going on with the update.

Hi, @Stephen_Cosgrove, sorry for a late reply. We are investigating this issue at the moment. We will post an update as soon as we have a clear understanding about what is the cause of this problem.

Thank you for your patience.


I am having exact same issue also. The workaround that Stephen suggested is working for me. I hope that a proper fix is coming soon.

Hi, @Mark_Nizza, @Stephen_Cosgrove , we were able to track down this issue and put a ticket in. Unfortunately, it seems like both of you are affected by the issue described in this thread – Some audio players not shown in player selection menu (1.8 build 880) [Ticket in]. Our dev team is already working on a fix.

Apologies for troubles.


Thank you Ivan, the response and update on the situation is greatly appreciated.

1 Like

Unfortunately Stephen’s solution almost worked for me - one device is always missing. My work around - in case it helps anyone until it is really fixed - is that Grouping still works. To use an endpoint not listed, I chose one that is (that’s won’t really be playing as it feeds a system that is turned off) and group it with the one I really want. Strange, but that is the nature of work-arounds.

The new update 882 that is available today seems to have resolved my issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.