Endpoints work via Airplay but not RAAT [Solved, Jumbo frames were enabled]

Today I’m unable to play anything and am seeing the “TIDAL a networking or connectivity problem is interfering with playback” as well as “ROON: an audio file is loading slowly. This may indicate a hardware or performance problem”.

My core runs on a dedicated Dell Latitude i7 laptop with 16GB of RAM and a 256GB SSD.
Control is from my MacBook Pro
Endpoint is a Sonore uRendu (into Devialet Expert 120) wired via gigabit ethernet.
My library is stored on a Synology DS1815

I have rebooted everything and am not experiencing problems with anything else on these devices.

Update: I hooked up my Aries Mini to the Devialet and ROON has no trouble playing anything to that device. It now appears to be something related to either the uRendu or the USB input of the Devialet.

I have the Devialet setup on both mR/ USB and AIR. Have you tried without the mR and directly via AIR. Also check the mR diagnostic (DAC diagnostics, under the Apps tab) on your Mac to see whether it is communicating with Devialet

The uRendu identifies the Devialet DAC - the diagnostics are pasted below. I’ve never had any luck getting AIR to work problem free, even the latest release candidate gives me flakiness (albeit greatly decreased)

Devialet Devialet USB Audio 2.0 at usb-ci_hdrc.1-1.1, high speed : USB Audio

Status: Running
Interface = 1
Altset = 2
Packet Size = 31
Momentary freq = 44100 Hz (0x5.8330)
Feedback Format = 16.16
Interface 1
Altset 1
Format: S32_LE
Channels: 2
Endpoint: 1 OUT (ASYNC)
Rates: 44100, 48000, 88200, 96000, 176400, 192000
Data packet interval: 125 us
Interface 1
Altset 2
Format: S16_LE
Channels: 2
Endpoint: 1 OUT (ASYNC)
Rates: 44100, 48000, 88200, 96000, 176400, 192000
Data packet interval: 125 us

Status: Stop
Interface 2
Altset 1
Format: S32_LE
Channels: 2
Endpoint: 2 IN (ASYNC)
Rates: 44100, 48000, 88200, 96000, 176400, 192000
Data packet interval: 125 us
format: S16_LE
subformat: STD
channels: 2
rate: 44100 (44100/1)
period_size: 2205
buffer_size: 4410
Simple mixer control ‘Devialet Clock Selector’,0
Capabilities: pvolume cvolume pswitch cswitch
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 127 Capture 0 - 127
Front Left: Playback 127 [100%] [0.00dB] [on] Capture 127 [100%] [0.00dB] [on]
Front Right: Playback 127 [100%] [0.00dB] [on] Capture 127 [100%] [0.00dB] [on]
Simple mixer control ‘Devialet Clock Selector’,1
Capabilities: pvolume pvolume-joined cvolume cvolume-joined pswitch pswitch-joined cswitch cswitch-joined
Playback channels: Mono
Capture channels: Mono
Limits: Playback 0 - 127 Capture 0 - 127
Mono: Playback 127 [100%] [0.00dB] [on] Capture 127 [100%] [0.00dB] [on]

That looks like at least mR and Dev are talking. What about the mR appearing as an audio output on Roon?

Yup … looks just the same as it always has. When I start playing music I get one of the two error messages within a couple of seconds depending on whether it’s local (NAS) or TIDAL.

The only other things I can think of trying are independently verifying the functionality of the Devialet USB input and resetting the uRendu to defaults and setting it up again, just in case …

The Devialet is one very intermittent beast in terms networking etc - but in your case looks like Dev is talking to mR - so I try to eliminate issues around mR and audio output first and then start looking at the Devialet - I can so relate what you are going through - damn annoying!

I hear you loud and clear. It’s a bit reminiscent of trying to get AIR to work reliably last year - I gave up on that.

Ironically, the problems with AIR had receded enough in my memory for me to be considering the upgrade … but then that same money would come close to buying me one of Mr. Rossi’s solutions and I’d still have the Devialet. I can’t make my mind up whether I should just slap myself for even considering the upgrade or whether it has merit.

In the same position buddy - have two Devs - 120 and 200 in two separate rooms - will go for the upgrade on 120 - I reckon there will be a noticeable improvement for the 120 and in my view a compelling justification to get into the 200 model bracket. Not so sure for the 200. I will do this after the xmas/ new year period as the holiday season may slow the turnaround time. Btw I use the new beta windows AIR - - and it is running swimmingly. The mR is now redundant in this setup.

I think I heard that the upgrade period ends on 12/25, so check on that before you miss the window of opportunity.

How does the SQ compare between AIR and uRendu? AIR doesn’t support RAAT does it?

I was able to get the uRendu working perfectly … but only using Shairport, which sounds sucky by comparison!

Hey - did not realise there was a timeline on the Dev upgrade - thanks for the heads up! The SQ comparison between uRendu and AIR is something I would not undertake in any hurry - I thought I was losing my mind!, you begin to imagine differences when there is so little or nothing different - bottom line in my setup I could not tell any differences in the SQ playback, both are stable and excellent SQ - I have decided for now to stick with the beta Windows AIR. Mind you if AIR does not work - mR is still on my network as plan B and on occasion I do switch between audio zones which is a simple operation from the iphone/ ipad. Both are better than Airplay via optical in my setup - my daughter sometimes fires up Spotify or Pandora via optical which sounds flat compared to Roon via either mR or AIR.

More clues.

  • Aries Mini via USB plays normally so I’m more confident that the Devialet isn’t a culprit
  • Sonore Sonicorbiter behaves the same way as uRendu as a ROON Ready endpoint - i.e. error messages
  • Both Sonore products play music from ROON via Shairport

Anyone have ideas what may have changes in ROON or where I can investigate?

I sent a log provided to Roon and I logged into the unit to have a look. I also head back from Roon regarding the log. It appears you have some kind of network issue that is unrelated to the microRendu. Roon has recommended that you look at your network for a possible place where Jumbo frames are enabled.

Thanks Jesus - that pointer took me less than 45 seconds to fix the problem. Since Jumbo frames on was supposed to be the default configuration for the ROON server I would never have found anything amiss and can only think that setting had not been applying correctly until a reboot or OS update.

Long story short all is well now and, for everyone else - don’t do Jumbo frames :slight_smile:

Everything is sounding lovely again!

1 Like

Hi Guys,
Just a note to thank you for this discussion. I was getting mad this afternoon with my brand new Auralic Aries…could not make it work as an endpoint for Roon (core on a mac mini), then I found this thread and disabled Jumbo Frames on my Mac Mini. Et voila’! Everything is working fine now,
Thanks , you saved me from a trip back to the dealer :slight_smile:

1 Like

Glad this helped! I know I would still be tearing my hair out if it weren’t for the outstanding support from Sonore!