EPOS H3Pro Hybrid Dongle not working on Windows 10 [Solved - Channels set to 7.1]

Serial #1C697A09AD88 Roon Core Machine

Windows 10 running on Parallels MacBook 16" pro with 64gb Ram (but same behaviour on Bootcamp)
MacBook Pro (16-inch, 2019)
2.4 GHz 8-Core Intel Core i9
64 GB 2667 MHz DDR4
Big Sur Mac Os
Parallels v. 17

This dongle broadcasts in 2.4ghz low latency lossless audio to H3Pro Hybrid gaming headset.

The dongle works fine on MacOS (multiple machines).

In Parallels, if the dongle is shared audio from the Mac, it works fine (ie running Roon in parallels and the selected audio device is the Dongle shared to Windows from the Mac Core audio driver).

However, if the dongle is directly connected to the windows machine (in parallels or in bootcamp), there are problems.

The dongle windows audio drivers are up to date.
Defender virus and firewall turned off.

I can play audio to the dongle within windows from tidal (either exclusive or shared) without problems.

However, when I play audio through Roon, eg start an album (via Tidal), it loads a track for one second (doesn’t play any audio), and then skips to the next track, rinse repeat, until it goes through the whole album in a few seconds.

I tried individually changing all of the settings for the audio device in Roon, and the behaviour doesn’t change.

it would seem that this isn’t a network or core issue given that the dongle works with Roon on Mac, and given that the dongle works with Tidal in windows.

Any suggestions?


Also, I had the same issue when installed in parallels on a Mac Mini, Monterey

Hi @Chickenlittle ,

In the Device Setup menu for this zone, have you tried to set the max sample rate to 44.1 or 48 and the behavior was still the same? Some gaming headsets only accept specific channel inputs, I would suggest trying 2ch, 5.1ch and 7.1ch to see if your headset only accepts this kind of input.


Interesting there was no option in Roon to adjust the max sample rate under advanced settings for this dongle.
(One thing to note is that when I clicked the “advanced settings” tab, nothing happened. It took me longest time to figure out to scroll down to see the actual new settings.!)

With a lot of experimentation I found out that the following settings worked for this Dongle in Windows:

Clock master: default
Channel layout: 7.1
Stereo/mono content as 7.1: yes
Multichannel mixing: either setting works (I don’t know what this setting actually does).

I also have it on non-exclusive mode so that the software that comes with the dongle can do EQ, etc…

Interestingly, the Advanced options are very different when the dongle is connected directly to Mac.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.