Error 504 when setting ARC on core pc

Roon Core Machine

pcמהדורה Windows 10 Enterprise;intel core i3-8100 cpu;ram8gb;3.60ghz

after the update stiil getting 504 error

"connectivity": {"status":"NetworkError","status_code":504,"error":"error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined"},
"external_ip": {"actual_external_ip":"213.ddd.eee.fff","router_external_ip":""},
"status": MultipleNatFound
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"server_ip":"","found_upnp":true}

Networking Gear & Setup Details

router d link dvg-n5402g fibernet 300 mb

Connected Audio Devices

ayre dac streamer qx8

Number of Tracks in Library


Description of Issue

i did port fowreding as instracted but still get this error

@rony_shema, I have moved your post to the #support:port-forwarding-help category, so it receives appropriate attention.

The port forwarding diagnostics you’ve provided suggest that UPnP is not properly configured on your router or not working correctly. Furthermore, I note that you have two subnets listed; this indicates double NAT. In addition to the D-Link router, what other devices are connected between the fibre line and the router? Incidently, the network is private, and the likely IP address of this ‘mystery’ device.

Please try the following steps in order:

Reboot your Roon Core and networking gear (router, modem, switches, etc.)
Try to enable UPnP/NATPMP in the web administration interface for the router
Try to manually open the port in your router’s port forwarding configuration
Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
Check for any VPNs or Firewalls that might be interfering
Try to update your router firmware
Check if your modem is in Bridge mode and if not, try to place into Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

What is the make and model of your modem and router?
Do you have any additional network hardware, like additional routers or managed switches?
Who is your internet service provider and what is your geographic region?
Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?


1 Like

i did all thethe above requrment -rebot/enable upnp/open manualy port/no firewall problams/ update firmware/there is no extra nat so the net provider say/ they say that if they put the router in bridge mode i wiil not have internet/ my router is D_LINKdvgn5042g/ no other router/ i am in isreal and my provider is nextcom via hot net

problam solved by network provider mix up of differnt IP

1 Like

Hi @rony_shema,

That is great news. If you have any kind of regression, please let us know!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.