"Error Adding Network Share to Roon on ROCK with PS Audio Directstream DAC" [Solved] Current Issue: Directstream DAC bridge not showing up as a Roon Ready device (ref#WYKFJQ)

Affected Product


Roon Issue Category

Installation or Setup

Description of Issue

I keep getting “an unexpected error” when trying to add a network share.

Roon Server Platform

Roon Optimized Core Kit (ROCK)

Roon Server Specifications


Connected Audio Devices

PS Audio Directstream DAC, bridge ethernet connection

Home Network Details

Roon server on NUC is connected via ethernet. Trying to point it to my music folder on my Synology DS218+ running DSM 7.1.1 update 6

You might start with this article

Thanks, I got the folder added now! However, roon is not pulling up the directstream dac bridge as a roon ready device. Any ideas there?

@Ben_Graessle, the DirectStream is a DAC, unless you have the Network Bridge option installed. Without the Bridge, it will act as any other DAC (and not be Roon Ready, which requires a network connection). What is shown in your Roon’s Settings → Audio tab?

I do have the network bridge installed. It is simply not showing up in my roon settings > audio tab, but every other device on my network is. I previously used mconnect app and that was able to find the network bridge, so I’m puzzled as to why roon can not.

Have you checked with PS Audio about any specific settings on the DAC that may need to be activated so Roon can see the installed network bridge?

I have, I spoke with them on the phone. They said to make sure it’s on the same network, and it is. I told them that the bridge is showing up on the mconnect app and they said it should just show up for roon as well. Not sure what to do from here.

Have you rebooted everything (router, ROCK, DAC) and see if that makes a difference?

Hi @Ben_Graessle,
Thank you for your patience while we worked through the queue. I can confirm that the Directstream DAC is a Roon Ready device. Can you check if the DAC is on a different subnet than your server?

It’s on the same network.

@Ben_Graessle sorry for the confusion. Subnet is different from network. Networks contain multiple subnets. Here is an example to help make things clear.
Same subnet (good)
Device 1 =
Device 2 =
Different subnet (bad)
Device 1 =
Device 2 = 192.169.1 .12
If you like to know more this article gives a good explanation.

To be honest, I don’t know about the subnet. Here’s what I do know. The wiim pro is connected to the same switch as the DAC. WiiM pro is seen by roon, the DAC is not. Mconnect also sees the DAC.

@Ben_Graessle just to be sure did you try @Robert_F’s suggestion of restarting everything? If that doesn’t solve it try plugging into different ethernet ports and check to see if your firmware on the DAC is up to date.

1 Like

Yes, I’ve rebooted everything. Firmware is up to date. I’ll try a different port.