Error checking for Roon 1.8 update

Roon Core Machine

Three Windows 10 i-3 PCs with 3.20 GHz CPU, 8Gb RAM running Roon Bridge 1.7 build 571; core is running Roon 1.8 build 806 under Audiophile Optimizer on Windows Server 2019 with i9-10900K 3.70 GHz CPU, 32 Gb RAM and EVGA RTX 2080 Ti GPU for HQPlayer CUDA offloading

Networking Gear & Setup Details

All three PCs at issue here are hardwired to Orbi router through ActionTec ECB-6200 MoCA devices

Connected Audio Devices

All three PCs used for MCH audio listening, with HDMI out for two of them and USB out to a miniDSP MCH DAC for the third

Library Size

246,466 tracks

Description of Issue

Core updated to Roon 1.8 as expected. Each of the three PCs at issue state that there was an error checking for an update. Perhaps there is no update for the PCs at this time, as my DietPi endpoints all say that 571 is the current version? Or, if there is, perhaps a bug, given that all three PCs did not succeed at update check? And if so, how do I manually update without losing Roon Bridge settings in Roon for each of the endpoints? Thanks. JCR

Hey @Jeffrey_Robbins,

Thanks so much for getting in touch about this, and sorry about the trouble.

Could you please reboot your Roon Core, the Windows Server (turn off, unplug, plug back in and turn on)? And then, navigate again to Settings → About and check for an update?

All of your Roon settings are stored locally in your Roon database. If you have been making regular backups, there’s nothing to worry about.

You can always re-install Roon fresh by downloading the installer from our website:

Please, let me know how it goes :nerd_face:

Hello, @beka. I shutdown the Roon core server, unplugged, replugged and restarted it. The same three PCs still show the same update error. So, that did not solve, unfortunately.

My Roon core backs up my database each night. I’ll do a manual backup now. If I then manually uninstall and reinstall Roon Bridge on the three PCs, it will be the core that will continue to recognize each one’s settings as a specified endpoint? I’m just confirming because I don’t know of any setting in Roon Bridge, as such, to back up its settings alone. Thanks. JCR

@beka, I have the same problem (message “error checking for an update”) with Roon Bridge running on my Windows 10 laptop. I have version 806 running for Roon Core as well as for Roon Bridge. This error message also exists with the previous version of Roon Bridge; thatt’s why I had to update it manually on my Windows laptop.

When I look in RoonBridge_log.txt on the Windows laptop I see a warning in Dutch: “Post web exception without response: De aanvraag is afgebroken: Kan geen beveiligd SSL/TLS-kanaal maken.”. Apparently it is impossible for Roon Bridge to make a secured SSL/TLS connection or channel.

I rebooted Roon Core and the Windows laptop. But that does not help. Please help and point us to the correct direction to solve this.

Hi @Jeffrey_Robbins / @Alfred_van_Hoorn ,

We just made some changes on our end regarding this, can you please check again and let us know if it’s working now? Thanks!

@noris, the error message is gone: problem solved. Thanks for the bug-fixing!!!

1 Like

Well, @noris, whatever you all did back behind the scenes definitely worked. All of the PCs (now a fourth in my home back up online) had the notice to proceed for install and relaunch, and they all have build 806 on them now. Success on my end, thank you! JCR