Error Checking for Update and General Systems Degradation ** SOLVED FOR NOW!

I have been running a new Roon Rock on an Intel NUC - configured per the Roon Optimized Core Kit guidance and overbuilt with 32GB RAM. Ethernet connected.

Yesterday I started experiencing multiple problems, odd behavior, and general performance degradation. I’m running updated software across the board OS, Roon Server, and RoPieee inputs. Versions: Roon Server Version 1.8 (build 790) stable, OS Version 1.0 (build 227) stable.

Rock Config:

  • Intel 7th Gen NUC Core i5-7300U, NUC7I5DNHE, M.2 and 2.5in Drive
  • Corsair Vengeance 32GB (2x16GB) 2400MHz DDR4 SODIMM Memory
  • Samsung 970 EVO Plus 500GB M.2 NVMe SSD (3500/3200)


  • Roon App on iPhone recently began crashing periodically in last couple of days.
  • Stalls on Quboz streams, that never existed before.
  • RoPieee XL End Points abruptly no longer in Audio section. They show up as Roon Bridge devices in my “About”. Been digging into that problem and posted here in community, still haven’t resolved. Likely will reflash them with RoPiee XL. Sudden Drop of Two Stable RoPieee XL RPi4 Digi+ Pro Wifi Endpoints
  • My Roon Server seems to have restarted audio analysis. Isn’t that done when you first set up and connected your library? In any case, it is about 80% done now. **Now completed.
  • In last couple of hours, I can now no longer connect to core from my iPhone Roon App. It now prompts: “Can’t find Roon Core” and asks if I want to select another core. I only have one core - my Rock. I can connect via my MacBook and I can see it on my network.
  • In the last 12 hours I have begun to routinely see “There was an error checking for an update” for the core, even though it is on the latest build.

I’ve been stable for weeks, no drops, no stalls, no app crashes, everything humming along and now encountering multiple stability and degradation problems. Any suggestions on where to go to investigate?

Continued actions/steps:

  • 4/30 AM Uninstalled iPhone Roon App and reinstalled and it does not fix my inability to connect to core from my iPhone. The iPhone continuously looks for my Roon Core and cannot find one my network. I see both my Rock and the iPhone connected to my network on my Google Home app. So I know both are on the network and my Macbook sees and is connected to core. I’m continuing to troubleshoot. **SOLVED: I did an IP scan via the Roon App on iPhone and entered the exact address fo my Roon Core and connected. On to the my other problems!!
  • 4/30 PM Swapped out my ethernet cables to Roon server, after seeing other do the same and resolve stability problems. Still testing.

Any tips would be appreciate!! Thanks so much for your time!

I’d try to test DRAM and SSD, your description is consistent with something slowly going bad in the memory subsystems. If you have two DRAM modules, shut NUC off, remove one and try to run it. Do that with either module, to see if there’s a difference. As for SSD, ideally you’d try to install ROCK on a fresh SSD to see if your current one is failing.

Since I run Ubuntu Server on my NUCs, I can examine system logs for hardware issues. It may be possible to do that with ROCK (since it’s Linux-based), but I don’t know how.


Thanks so much for the suggestion. Will dig into it some and advise!

Here’s how to access logs, ROCK is toward the bottom of the doc.

1 Like

Thanks much!! @Fernando_Pereira


I am still digging into my problems here and haven’t given up! Thanks for the help thus far.

A general question for the community:

I was extremely careful in building my Roon Rock to the optimized kit requirements and even overbuilt it to try to avoid having to tinker and deal with problems. I now I find myself having to get into the technical weeds to figure out how to get my Roon system to work in a stable manner.

Are there available platforms such as the Nucleus or Lumin or others that can largely eliminate dealing with stability problems when running Roon? Or is Roon simply going to always have the risk of not being stable with it because it is a newer platform and is so dependent of the network environment one deploys it on? I don’t have an issue with dealing with instability for net new stuff, but I felt I had chosen a path that was going to largely mitigate risks of stability and glitches. If this is the way it rolls with Roon, I will probably just buckle up for the ride and roll up my systems support sleeves and look to figure out my problems over time. However, I am open to potentially changing up my system to avoid burning time to keep my system working, if there is some material level of risk reduction with other platforms.

Net net - what stability expectations should I reasonably have with my current set up noted above?

Thanks so much for any insight or perspectives you might have.

You should reasonably expect it to be Rock solid (pun intended :grinning:). Seriously, your expectations are not unreasonable in that the system should be flawless. Having said that, I think we all recognize the inherent weaknesses of computer systems. Hard drives and memory fail. Even power supplies can crap out. That’s just an inherent downside to this particular hobby. Most people have the premium experience. Sometimes you just have bad luck. That doesn’t mean you shouldn’t expect the best.

Thanks @David_Gibson That comment helps. I can deal with the one-off problems and being unlucky! Heck I may be the main source problem. : )

Will keep working it! I’m learning a few things along the way!!

Please power cycle your whole network, starting from the router, including all network switches, Roon Core, and all endpoints, and iPad.

Because this is a network of many different pieces of equipment, all have to be functioning correctly for Roon to work. Unless you happen to have isolated the problems to single a piece of faulty hardware, I don’t think yours is a case of simply buying something then everything will work again.

1 Like

Thanks for the advice @wklie. I will do that.

I am in the midst of re-flashing one of my RoPieee’s to see if that resolves my RoPieee’s not showing up as an Audio device choice for Roon. Once that is done, I will power cycle all elements of my network and system.

@Wklie The full power recycle seems to have set things straight!! I now see the RoPieee endpoints that previously only showed up under “About” as a Roon Bridges. As well as a few other Chromecast and Airplay endpoints that I don’t use, that I had dropped off as well. Those now show up.

I don’t know why I didn’t go the route of “Control Alt Delete” earlier and I appreciate the direction.

I will continue to monitor the performance. Hopefully, this reset puts me back on the path of stability!

Thanks again for your time to advise!

Great. What WiFi router or WiFi access points are you using?

Something in the network infrastructure is dropping multicast after running for some time. This is not uncommon with consumer network equipment, and that’s why power cycling the whole network worked.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.