Error checking for updates everytime [resolved: user error]

Core Machine (Operating system/System info/Roon build number)

Windows 10 64

Devialet D 200 via ethernet

I have the same problem every time that a new version is launched. Now it’s happening with the version 1.7 (555).


is it possible you have done something to prevent updates? like change your hosts file to block out ?

I do not know. The installation was done by a friend. If he did, how can I reverse?

The latest version, 537, was updated, but it took a few days. But version 555 is not being updated.

Windows 10 64

Devialet D 200 Ethernet

I’m having trouble with Tidal’s favorites, and I can’t update Roon to the latest version. I already opened a call in the community / suport, 04 days ago, and so far I have not received an answer. I consider this a terrible service for $ 120 a year. I am considering canceling the service and requesting a refund.

Windows 10 - 64


TP Link Archer C6 - Gigabit port

Hi @Paulo_Sergio_De_Lore,

Please accept my sincere apologies for the delayed response here!

As Danny mentioned above, most of the time this is caused by either a networking issue or something on the Core machine that is blocking the connection.

Since experiencing this issue have you tried rebooting the Core machine?

Do you have any antivirus or firewall that might be blocking the connection? If you disable them temporarily does the update proceed?

If neither a reboot or disabling antivirus/firewall helps, can you give some details on your networking setup?


I tried and nothing.

I tried and nothing

What information about my network do you need? I think it can be something like " change your hosts file to block out

open a browser, visit:

do you see:

403 Forbidden


or do you see something else?

Problem solved. There was a block on the host file. I managed to reverse the block and the update started.

Yah, this is your firewall or your computer.

I just asked your system for diagnostics logs, and it looks like your machine is resolving to – this is a common technique for pirating old versions of Roon. I’m not saying you are a pirate. Maybe your friend installed via an unofficial Roon installer, or some other strange download he found online?

I’d ask your friend to undo whatever he did, and grab the proper build from – it is important to undo whatever he did though or the new install will not work.

On Windows, this is often done via the c:\\windows\\system32\\drivers\\etc\\hosts file. Check that file.

1 Like

perfect… do you know how that block got there?

I’m just waiting for the update to download. It’s a little slow.

I dont know how. When I first installed the software the service was done by a friend. Perhaps he made this change. When support mentioned that this could be the problem, I looked for a tutorial and managed to revert.

I completed the update and the problem was solved.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.