Error: Failed to Initialize the Audio Device

I have a feeling it’s getting worse. However, I’m watching more closely now, so maybe it actually just feels that way.
The error occurs most often when I stop playback for some reason (e.g. because of business phone calls) and then want to start playback again. In about half of the cases, the error appears at that moment. Occasionally it also happens when a song is over and the next one should start - but doesn’t.
What I have not yet tested sufficiently is whether the error also occurs with the local library or only with Tidal/Qobuz.

Hello @benjamin
is there any news?

Hey @Andy211,

After discussing this issue at length with the team, we’re curious to see if exclusive mode is enabled for the McIntosh DAC? And if so, can you test disabling exclusive mode to see if your issue persists?

Hello @Benjamin, I disabled exclusive mode for the McIntosh DAC and have not received the failed to initialize error message. I’ll keep trying, because I’ve noticed that when I think the issue is resolved it comes back. I did receive the “No audio devices found” twice.

Hi @Benjamin , I used Roon again last night and today. I no longer get the failed to initialize audio device message. I have tried on my library, Qobuz and live radio. I only received the no audio device found message once. Disabling the exclusive mode for the Macintosh seems to have stabilized things. I’m now wondering, what does this mean? Is it a problem with the DAC, Mac OS or something altogether different? As you know, disabling mode means all tracks are played through the DAC at 44.1khz, so I can longer play tracks in their original bit rate if they are higher than 44.1khz. Is this more or less permanent for my system, or is there still a potential fix? Thank you again Benjamin, I really do appreciate your help and the fact that you have not given up. -Andy

Hey @Andy211,

Thanks for giving that a try! It certainly makes this issue a bit more interesting.

Turning exclusive mode back on, and going back to your audio midi setup from your Mac core, I’d be curious if it also disappears from your core’s settings. A tedious thing to test, but if you keep the audio midi settings window open, and go about your listening as you normally would, and when you get the error in Roon, see if the DAC also is removed via audio midi on the core device as well.

If so, that points more to an OS issue with Ventura.

Re-reading this sentence, it is unclear if you tested your setup on a completely fresh database before restoring from a backup? Let me know!

Do you by chance have Time Machine running? We have a complicated relationship with Time Machine, and I’d be curious to see how things run if you temporarily disable it. If you are running Time Machine, I would also suggest setting it to ignore everything Roon related.

Lastly, do you by chance have a windows PC you could test out as a core device, and see how the DAC performs there?

Hi @Benjamin, I’ll try these recommendations and report back to you. Yes, I do have Time Machine running, I’ll follow your suggestion for Time Machine and see what happens. Regarding the quote, “I followed your steps, deleted the RAATServer folder and the Roon folder. I reinstalled Roon, and started it up. The library seems much more stable now.” I did test the setup on a fresh database before restoring from a backup. I believe I tried it twice. Also, the library did seem stable, for a while at least, and then the error messages started again. I’ll let you know how your recommendations work out. Thanks, Andy

1 Like

Hi @benjamin, here are the results…
I turned exclusive mode back on, and opened the audio midi setup on the Mac core. The DAC did not disappear from the core’s settings windows when an error message appeared in Roon. So even though Roon said it failed to initialize the device, the McIntosh DAC was not removed from the audio midi on the core device.

On Time Machine, I excluded the Roon Application and the Roon Backups folder that I have from Time Machine. I then put Time Machine into manual mode, so it would not run on its own. I disconnected the external drive from the Mac mini that I have dedicated for Time Machine. I restarted the Mac mini and then tried Roon again. I still continued to receive the failed to initialize error message. I also double checked that the McIntosh DAC was not removed from the audio midi on the core.
Thanks, Andy

Hello I’m also experiencing this problem constantly with the chord Qutest / Qobuz on a Mac mini with Ventura 13.2.1 (almost every time I switch to another album for example)

1 Like

Estou com mesmo problema. Tudo começou com o Ventura no Mac Mini.
Tenho o MacBook Pro com Monterey e o problema não acontece.
O Roon deve resolver o problema rapidamente, assim com cobra rapidamente.

1 Like

The only solution is to downgrade to macOS Monterey.

I’ve read that Ventura 13.3 will be released in the next week or two. It’s supposed to fix a problem with file sharing within the same network, not a Roon problem. I’m interested to see if Ventura 13.3 will also fix the problem we’ve been having with Roon. If not, downgrading to Monterey is a really good idea.

Então, vamos esperar.

I agree, it makes sense to wait. I think the Roon time is trying their best to figure it out.

Hello @benjamin, Today I updated the mac OS to 13.3 Ventura. It was just released. So far after the update, everything seems to work. My library, radio and Qobuz. I’ve been here before where everything seemed to work, only to have it revert back the next day. I’ll repost in a day or two to confirm one way or the other. I’d be curious if anyone else had a chance to update their OS and what they are experiencing. Thanks, Andy

1 Like

Olá! Também atualizei e parece que não tem mais o problema. Vamos aguardar mais um pouco para bater o martelo.

1 Like

Hello @benjamin I think updating to Mac OS Ventura 13.3 was the answer. I’ve been using Roon the past few days and have not received any error messages. For anyone else who may be experiencing these issues with Ventura, I’d recommended updating to 13.3. @JOAO_JOSE_Da_Silva, I hope your system is still working good since you updated.
Tomar cuidado!, Andy


Ok! Andy211. Testei exaustivamente com o OS Ventura 13.3 e até o momento não apresentou problemas. Joao Jose



Thank you for the detailed update, I’m glad to hear updating Ventura has solved your issue! Now, for the most important part here - happy listening! :notes:

1 Like