Error loading folder Unauthorized - After upgrading to the latest version (1353)

Roon Core Machine

Mac Mini M2 16GB RAM
MacBook Pro M1 16 GB RAM
both on the latest OS

Networking Gear & Setup Details

Synology NAS DS1522+
Netgear Switch GS308E
FritzBox 7590 router

Connected Audio Devices

Number of Tracks in Library

150k+ tracks

Description of Issue

After upgrading to the latest version of roon on both Roon core (Mac Mini) and Roon on MacBook I receive the error message “Error loading folder Unauthorized” when Roon tries to connect with my Synology DS1522+ NAS. I’ve rebooted all devices and (in addition) tried to reconnect by adding a new network connection. Nothing solved the problem. Then I’ve tried to connect to a DS218play also available in my network. Unfortunately this resulted in the same error.
All other attempts accessing both NAS are successful. I was able to connect via Finder, VLC, Apple Music, …
Any idea what I can try to fix the issue?

Hi @Andreas_Heinze,

Thanks for writing in! The first thing I’d investigate is your firewall settings on your Mac. Can you confirm you have the following listed as exceptions:

Which Mac are you sharing the NAS with? Can you confirm the share settings have not changed:


Hi @benjamin,

thanks for your help.
I was able to solve the problem in the meantime. It wasn’t the firewall. It was the Security & Privacy settings on the Mac Mini. After changing the Files & Folders access rights on the Mac Mini for Roon to full access Roon was able to find all files an my NAS again.

I wonder why this happend lately after all the month not having a problem at all. Either the lastest MacOS or Roon update “takes care” of these rights and blocks the access if not set correct.

Nevertheless I’m happy to be able to use Roon like I did before.

Kind regards and thanks again


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.