'Error loading page' error message appears frequently since 1.7 upgrade

Core Machine (Operating system/System info/Roon build number)

Intel NUC8i5BEH/Roon app on Windows 10\Linn KLimax DS/1/Synology 216+ local NAS & Tidal Masters. Roon 1.7, build 500.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Sky Q Hub router/Cisco 2960 switches/Cat6 ethernet connection

My experience is that Roon was pretty flawless prior to the 1.7 upgrade. However, I now experience quite a few problems that are a little irritating.

I regularly get an ‘Error loading page’ message even although the page appears to have loaded correctly. The message disappears if I click on the ‘Reload page’ option - see screenshot below:

I also frequently find that selecting an album results in a blank page being presented (no error message - completely blank page). Paging back and re-selecting the same album always brings up the album correctly.

These issues are in addition to the one I posted earlier on November 23 - Roon Radio intermittently fails to provide album artwork or artist/album details for tracks it selects for me.

Each of these problems have begun to occur post 1.7 upgrade and were not present before the upgrade.

Hi @hmack,

How often does this occur? Does it happen only when opening the TIDAL page in Roon or does this happen elsewhere? Does this only occur when you first start the app?

Is this only for TIDAL/Qobuz content or does this happen for local content as well?

Hi @dylan

“How often does this occur? Does it happen only when opening the TIDAL page in Roon or does this happen elsewhere? Does this only occur when you first start the app?”

This happens when I open up the app for the first time. I am pretty sure it has happened more often than this (always when opening the TIDAL page) , but at the moment it appears to be happening only on the first time I access the TIDAL page.

I should add that this problem occurs on my Windows iPad Roon app as well as on my Windows 10 Ron app, and on the iPad the error message appears on the Tidal page every time I page back to it, but disappears once I have chosen the reload page option.

“Is this only for TIDAL/Qobuz content or does this happen for local content as well?”

This problem was occurring fairly regularly, and I think that it was always with TIDAL content. However, I can’t be certain because since you have replied to my post to ask these questions I have not been able to replicate the issue (on my Windows 10 control app) to check for sure. Strange! However, I have been able to replicate it on my iPad Roon app - so far only with TIDAL content.

I subscribe to TIDAL but not to Qobuz so I can’t test for the same issues on Qobuz via Roon.

The other problem I reported earlier (missing artist/album/artwork details in Roon Radio selections) still occurs regularly.

Hi @hmack,

Can you try using Google DNS and let us know if there is any improvement?

1 Like

@support

I have been getting this get this message fairly regularly since the last major update (with Tidal in my case). Most of the time the message appears even although the album details do appear to have been loaded correctly. Choosing the ‘Reload page’ option gets rid of the erroneous message.

This may be linked to other problems I now have:

  1. Albums that I select sometimes just display a blank page - I have to page back then select the album a second time, at which point they appear successfully.

  2. Roon Radio (for discovery purposes) works perfectly from a music replay perspective. However, if I click on the small icon at the bottom which displays artist name, track etc, then around 30% of the time the page which ought to display further details is completely blank.

I have reported this along with my system details on a number of occasions, and have been told that it will be looked at, but there appears to have been no follow up in the months since then.

I know that the latest major Roon update has resolved a number of issues for some. However, it is particularly annoying for me since up until the update I had virtually absolutely no problems whatsoever.

Hello @hmack,

The last communication I see here is from @dylan to you, have you by any chance had a try to use Google DNS? Has it improved the behavior at all?

Hi Noris,

Is there any evidence to suggest that using Google’s DNS rather than that of my ISP will potentially make a difference? Has this worked to resolve similar issues that other people have had?

The problem I have is intermittent, and from an intuitive perspective a problem related to DNS would be likely to be constant and not intermittent. Would you agree with this?

I am a little reluctant to switch to Google for a number of reasons, unless you have evidence that this could potentially resolve the problem.

Incidentally, I have just logged into my router and although I can see the DNS that is used by my ISP Sky (UK), I cannot see any way of changing to Google DNS or any other DNS service. Sky uses 90.207.238.97 and 90.207.238.99 as its primary and secondary DNS servers. Is this information of any use to you in diagnosing my problems?

Hi @hmack,

Yes, using another DNS has often resolved similar issues, particularly for media playback but it could also help in your case as well.

This is because ISP DNS servers are not always the most reliable ones, we suggest to use Google or Cloudflare or Quad9 whenever possible.

Have you been able to see this behavior on any of your other Roon Remotes, or is it solely occurring on the Windows one?

HI,

I don’t know the answer at the moment because I almost always use Roon Radio on my main system with a Windows PC Roon Remote control point. However, I will test this using my iPad over the next couple of days and report back.

1 Like

Hi Noris,

I have just replicated the problem on my iPad, 3rd track into Roon Radio at 09:13 (am - UK Time).

I started by playing a track (“Inner Kiss”) from the Govi album “Luminosity”. The first track selected next by Roon Radio displayed all details OK, but the next again track replicated the intermittent display problem.

The small icon at the bottom of the display screen indicated that the track playing was “Barcelona Dreams” by Behzad. However, when I select the icon to display further details, the ‘display details’ screen is completely blank - no information or artwork whatsoever.

Next track selected by Roon Radio is “Back to Earth” by Back to Earth , and this time when I select the icon at the bottom of the screen, the display details screen is fully populated with both artwork, album details and also appropriate links.
Next track by Govi - all details (background photo, album artwork, albm details and links) displayed perfectly.
Next track by John Adorney (“This Wonderful Game”) - completely blank details screen
Next track by Eric Tingstad (“Dripping Springs” - background photo present, but no album artwork or details.
Next track by Peter Kater (“Bamboo Dance”) - all details (background photo, album artwork, details and links) displayed perfectly

So, the problem occurs (intermittently) for me pretty identically on both Windows 10 and IOS (iPad) devices.

Incidentally, I have just contacted my ISP’s service department (Sky UK),and they have confirmed that there is no option available to change DNS server settings via the Admin pages on the Sky Q router.

It will not be possible for me to try Google DNS to check whether or not that could potentially resolve my problem.

It appears to be the case that my ISP locks down DNS to its own defaults on my router. However, DNS settings on end devices can over-ride router settings. In my particular case, would the end device be Roon Rock on an Intel NUC? If so, is there any way for me to configure Google DNS on the NUC/Roon Rock?

Hi @hmack,

Yes, you can manually configure the DNS on the ROCK Web UI and on your Windows Client by using these instructions.

To configure the DNS on ROCK, you will also need to set a static IP address that doesn’t change. I would be careful when assigning this IP, as ROCK will then always try to use this IP, even if the router tries to assign it to other devices on the network.

To ensure that ROCK will always have this IP address, most routers have a Reserved IP address capability, where you configure a device to always use on specific IP address.

If your current router does not support Reserved IP or changing DNS servers, you may want to look into purchasing a consumer-grade router that does.

Unfortunately, I have been advised that even if I configure the DNS on the Rock UI and Windows client, my ISP (Sky) will over-ride any non Sky DNS Servers I try to reach.

Members of the Sky Community forum have told me that my only option would be to run my own DNS server on a Linux box, or use a VPN with DNS leak protection.

I don’t want to go this far simply to check whether my problem is DNS related.

@noris

As you can see, changing to Google DNS is not really an option for me. Do you have any further suggestions?

I am a little sceptical about Sky DNS servers being the issue, given that my problem only started after the recent major Roon 1.7 update. Why would the DNS servers be causing problems now when they weren’t before the 1.7 update?

Hi @hmack,

I can take a look at your Roon logs to see if that provides more information. Before I go ahead and enable diagnostics mode for your account, can you please reproduce the behavior you mentioned and note the exact local time + date it occurs at, as well as which Roon Remote/Client you were using at the time?

Hi @Noris,

I have been in Roon Radio mode from 18:40 to 1940 (UK time), and although I was briefly out of the room for 5 to 10 minutes, I have not been able to replicate the problem so far today using Windows 10 Roon control app and my Linn Klimax DS/1 streamer…

At least 11 tracks have played where the Background Photo, Album artwork, track and Artist details have all displayed correctly. I am pretty sure that this is the most successful stretch of Roon Radio selections without any issues that I have had since I first noticed a problem. Has anything changed to resolve the problem?

I have also not been able to replicate the ‘Error loading page’ message today.

I will try again over the weekend and post back to let you know if the problem recurs.

Thanks.

Still no problems up to 20:15 - that’s 1 hour 30 minutes.

Has anything changed?

Hello @hmack,

No, nothing has changed on our end. Since you’re unable to reproduce this, it suggests that it could be something environmental on your end, maybe when you called your ISP they changed something on their end?

HI @Noris,

Strange - I’m pretty sure they didn’t do anything, and I certainly haven’t changed anything. The guy I spoke to wasn’t very technical and had to speak to someone & get back to me with the answers.

I’ll run through a test at the weekend to see if the problem has really gone. Today is the first time since the 1.7 upgrade that I haven’t encountered the issue.

1 Like