"Error saving changes, please try again later" metadata issue

Hi guys, I seem to be getting this issue whenever I try to automatically tag an album that Roon has identified correctly. I have linked the error message I get above.

There is also a separate issue where Roon does not resolve identifying an album and remains stuck on the “searching” screen as shown below:

I thought it was perhaps a server issue, but it has remained for about a week now. I run Roon off Unraid and am trying to do this action on Windows 10. I have restarted both machines several times and it seems to make no difference. My internet connection is fine.

Weirdly I have no had this issue before, but seems prevalent now in the last week. Nothing has changed at my end as far as I can tell. Any insight is much appreciated as I’ve searched on here for this term and got no where.


Hi @ultrafud,

Can you reproduce this once more and make a note of the time that this fails as well as the name of the album you’re trying to identify? We’ll enable diagnostics and take a look. Thanks!

Various Artists - David Haffner’s Disco with a Feeling @ 19:56 GMT

Hi @ultrafud,

I just wanted to let you know that the diagnostics report was received and I’m working with the team on investigating this. I’ll follow up soon.

Thanks for the help, if you need me to replicate the issue let me know as it is still persisting with other albums I’m trying currently to add.

Any update on this? Still having identical issues.

Hi @ultrafud,

Apologies for the delay here. With the holidays over the last couple of weeks our queue has been a bit slower than typical, but I have a meeting scheduled to discuss this with our team soon. I’ll follow up once we’ve discussed!

Slight update, I’ve found if I just repeatedly try and get the meta-data to save, it will work eventually. At most I’ve had to click “Ok” on the error message and try to re-save about 10 times in a row before it goes through. So it does seem to work after a certain amount of tries, unfortunately the number of efforts it takes to go through seems to be random.

Hi @ultrafud,

I spoke with the team about this yesterday. In the logs we are seeing signs that this might be something local to your database rather than an issue with the connection to our servers. We are hoping you can help us test this theory.

Can you try starting a fresh database on your Core machine, sign in again, and give this a try? Does it work for you when you do that?

Please note that you’ll want to be sure to make a backup before doing this so you can recover it later.


Hi Dylan, thanks for your response, I will give this a try when I have the energy to attempt it.

Unfortunately I’ve been having massive issues with Roon the last few weeks with my entire database crashing repeatedly, unsure if all the issues are related, but I suspect they are. There seems to be something wrong with the docker on my unraid server, but despite several clean installs I seem to be running up against issues repeatedly and the core seems to be stable for a day or two at a time.

Hi again Dylan,

So I did what you asked and tried starting a fresh database and added a single folder with a single album that I knew I was having issues with before. The album metadata was fetched automatically without me doing anything at all…so, progress?

Unfortunately that means there is something wrong with my database, however I cannot really afford to do a fresh start as there are dozens of hours of manual meta-data and playlists that I have created that I really do not wish to lose. Any advice?

Thanks for the insight here, @ultrafud.

Do you have any backups from before this issue started occurring?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.