Expert Pro is finally Roon Ready

Yes I still don’t understand why this is being labeled a Devialet problem, Roon’s stated objective is that they do not award Roon Ready status until it is thoroughly tested and signed off as 100% perfect.

This is a Roon problem, whether the error is with Devialet or not, Roon should not have given it Roon Ready status with obvious problems existing.


Well, I had a minor success today: I had both Roon Ready and Roon Devialet AIR enabled. Problem was they both had the same IP address. I should have realized that was a conflict. So, I disabled AIR, turned off my Roon Nucleus and then rebooted the D220 and Roon Nucleus in succession. Now, at least, Roon Ready doesn’t come and go and I can play songs without any dropouts. I still have slow loading media from Tidal and track skipping but it’s leagues better than before.

This is ok, they are different protocols to the same endpoint (device).

I keep both Roon AIR and Roon Ready enabled and can readily switch between them. Since both are using ethernet to my Expert Pro, they do share the same IP address. The only problem I’ve experienced is that Roon Ready will not work well at gigabit network speed.

That’s good to know, thanks. Well, I’m staying put for the moment as at least I have a somewhat workable solution.

Hello All,

Please see an update to this issue here:

– Noris

I am one of those having recurrent problems with a Devialet Expert 220 Pro and streaming via Roon. I decided to use a 100Mbps switch to connect the Devialet, as a Gigabit connection is a non-starter. It works fine for a few days this way and then the problem recurs. The short-term fix is to unplug the Devialet and pull the SD card so it reverts to a factory configuration; then I push the the SD card back in so it loads my preferred configuration. Obviously, this is not a long-term solution.

I have conveyed the issue to Devialet. Today, Karen responded with these two questions, with my responses in bold:

  • Does the Devialet Expert app on your phone still work? (i.e., control of the amp and visual feedback of the screen). The answer is no. The Devialet app, whether on my phone or iPad, just doesn’t connect.
  • the device continues to collect an IP address, this being visible from the info menu on the Ethernet or WiFi interface? The answer is no. The IP address (Ethernet and WiFi) on the information menu comes and goes, as if the device were getting a signal and then not getting a signal.

So, consider this an update for those of you having similar problems. Not sure what Devialet might be doing after months of this experience…

This problem of internet flicking on and off seems to be highly dependent on internet configuration and set-up. I had the problem, sorted it out and it has not come back. I use Devialet Roon Ready most of the time. It works wirelessly and, when I plug in the ethernet cable, wired as well.

Prey, do enlighten us…

My system is wired ethernet with a wireless access point next to the Devialet. Between the access point and the Roon server (Innuos Zen Mk3) is a 100mps switch with fibre output, which is converted back to ethernet before going in the server.

The little trick I have to do if I ever have to power it up (like last week when I had some electrical work done) is to unplug the ethernet cable to the Devialet, switch it all on and play something via Roon Ready in wireless mode, which works fine, but I then plug in the ethernet cable from the server to the Devialet and operate it in wired mode.

The problems were powering up with both wireless active and with a wired ethernet connection.

p.s. It is not a dedicated network. I use the wired connection for audio and can stream 192/24 audio and watch HD video on my computer (sport with the sound off) from the access point at the same time with no break-up of either stream.

You can’t run both simultaneously, plugging in an Ethernet cable will disable WiFi, and visa-versa.

That’s what I do. Start it up with the ethernet cable unplugged and it works by wifi. I then plug in the ethernet cable and it disconnects the wifi and works by ethernet.

It also works with uPnP, Spotify and Airplay no problem at all.

That’s just the way I start it up to get it to work perfectly with a direct connection from the Innuos Roon Server. I find it the best way as the Zen Mk3 has an ultra-low noise ethernet output. The incoming ethernet signal comes from a fibre optic cable converted to ethernet using a converter powered by battery, and the server and Devialet are powered using Shunyata cables and Shunyata Venom distributor. So it’s all wired and very low noise with very clean power. No computers or transformers anywhere near it.

The usb is also very good and unltra-clean, but you can’t use Devialet auto-detect, which is one of the best things about it.

I keep thinking of getting a Devialet to use with my Nucleus, so thought I’d check here to see if it’s all working now. Seems I’ve got to keep waiting…I thought it was a Roon Ready now? Sounds like it’s really not.

It works and sounds great if you use AIR instead of RAAT. Streaming via Roon RAAT to your Devialet Expert Pro does pose problems for many if streaming via gigabit ethernet. But generally, if you use wifi to your Devialet or a slower 10/100mpbs ethernet, it seems to work fine - at least most of the time.

The problem is in Devialet’s court so hard to say when it will be resolved. If you do experience the problem, I’d suggest logging a ticket with Devialet.

I appreciate that Michael has issues, and I’ve seen his posts on Devialetchat as well, but I have common UK ethernet equipment and have had no problems with Roon Ready on Devialet, using gigabit ethernet, wifi, fibre and usb connections.

Don’t know which dealer you use, but Paul at Hifilounge is not far from you, he is a Devialet and Roon dealer and provides excellent service and support.

If you are ever coming down the M1to the big smoke, I’d be happy to accomodate a trial with your Nucleus.

Let me add that I see no reason to wait if interested in Devialet, a Nucleus and Roon. Roon AIR works great as does Roon RAAT if using wifi to the Devialet or a 10/100 mbps ethernet connection. The problem I mentioned is only occurring via Roon RAAT when using a gigabit network connection and, as @Steven44 points out, there are people that are not experiencing this problem at all.

And, WiFi works fine too, so as said, you have several options that are problem free.

Hello all,
i own a devielat exprt 220 pro and a 400. I moved from my old flat to a new one these days. My Network Setup before i moved:
Fritzbox(Modem/Router) => Fritz DLAN 1000E =>5 Port TPLink Gigabit Switch => Devialet & RoonServer

This Setup had the Dropout issues.
Now i use a new Setup:
Fritzbox(Modem/Router) => Brocade ICX6610-24E Switch => Devialet & RoonServer

This is a Enterprice Switch with very good switching capabilities and since this switch there are no dropouts any more.
The Devielat runs with 1000Mbit. So i believe that these issues are Network related and if proper Network hardware is used the Devielat works as intended.
In my case the Fritzbox is the DHCP Server but does not need to do any switching.

This is just a update from me. Anyone else with newer informations?

kind regards,

Good to hear that you’ve had better results with your new configuration, but I think you might be over-generalising to suggest that using “proper” network hardware will solve the problems that other people have experienced. (I know, I have a tendency to do the same thing. :slight_smile: )

1 Like

I have tried quite many different network devices and configurations. Like:

  • Different gigabit switches (D-Link, TP-Link, Netgear)
  • Different routers (Netgear Orbi, Asus GT-AX11000) & different settings on these routers
  • Different network cables
  • Connecting all devices directly to the router vs. to a switch between
  • Running Roon Core on two different Nucleus+ and one W10 PC

Only in one of these combinations I finally got RAAT streaming to work perfectly fine. In my case this was with TP-Link 5 port switch, Asus GT-AX11000 router and one of the Nucleus+.

For example, if I run Roon Core on a W10 PC in the same network, I got all the problems.