Expert Pro is finally Roon Ready

How is this going to change the way Devialet works with Roon?
Andrea, Rome, Italy

I suspect the biggest benefit of Roon RAAT over Roon AIR is that it allows you to have multiple Roon Ready systems playing back in sync simultaneously (e.g. my Devialet system in the living room and another Roon Ready system in the kitchen). The only way to do that with Roon AIR is to have multiple Devialet Expert systems.

I have just installed the new Roon Ready firmware on an Expert Pro 220 and the Devialet indicates a Roon Ready function. However, my Roon core fails to recognise this as an option; i.e. still shows networked ethernet connection via Air and an Airplay option, both of which work fine. Wondering why my Roon core fails to recognise the new option? Have tried multiple reboots of the Devialet and MacBook that functions as the Roon core. Wondering if anyone has the same issue or can offer any insights?

Have you checked that it is enabled as an output in the audio settings in Roon?

Thanks for that but unfortunately there isn’t a Roon Ready option to enable in audio settings. Seems that Roon core doesn’t detect the new option on the Devialet.

Try resetting everything: Devialet, router, core, apps… this is what worked for me.

Oh wow, Expert Pro is now Roon Ready. I totally missed the news as I was abroad for a few days. I need to get my Devialet Expert 120 upgraded to the Expert Pro 220 presto! Nothing’s holding me back now!

Mine is simply listed as Devialet Expert 220 Pro in the audio settings. It is only when you click on the little blue i button that it indicates that it is RAAT.

I have just done the same i.e. upgrade my Pro440CI to the latest firmware. Like you, I get the Roon Ready input on the amp but no RAAT output in the Roon settings that I can activate and then use.

Air is still working fine.
I connect my Devialet to my ethernet via wifi by the way.

My Roon core (macmini) also fails to see the Roon Ready networked Devialet. Airplay works fine. All by wired ethernet.
The Devialet (220 Expert Pro) can be selected to a new Roon Ready input (it nicely shows the Roon logo:grinning: , but Roon does not seem to find it.
I have tried the tips above without success.

I’m still on a Roon trial (although I have an Innuos server arriving next week and I will be signing up), so a novice, but I followed the install instructions in the Devialet update file to the letter and everything was fine and working in a few minutes.

1 Like

This is audio Nirvana - finally from source to the speakers - RAAT- can’t get much better than this! Thank you to the team in Roon, you guys are making a huge impact on both hardware manufacturers and streaming services - at the end of the day good quality software development that brings joy to the person who buys these devices cannot be ignored - “Roon Ready” is now has brand equity that is equal to the hardware the Devialet engineers have put in the box. And the results are immediate to one’s ears!

Unbelievable development from the team at Roon the last 18 months with addition of new hardware and streaming alternative including Qubuz, MQA first decoding - I am now only seeking “Roon Ready” solutions as that certification gives me the confidence of an audio solution that meets my need. Well done and don’t let the 'naysayers" distract you from what you are guys are doing here which has taken the audio industry in the software domain 10 steps forward just in last two years - where this industry has been struggling the last two decades since he arrival of SACD/ DVD -A. Well done guys!-

1 Like

Thanks Paul. I did check the blue “i” button and it simply said “My Devialet-ETH” and indicated an ethernet connection. Nothing about RAAT.

Have noted a few new comments in this thread with a similar problem to mine; one also using an Apple computer to host the Roon core. But that’s probably just grasping at straws.

This sort of thing is totally frustrating! At least the Roon Air option is still working OK. I hope this is resolved soon for you.

@Paul_Williams Not sure this will help but check this thread regarding “Disable IGMP Proxying”…

Thanks, but alas my router is already set at IGMP Proxy disabled

@Ruud_Verrijk That’s a pity it didn’t solve your problem. Must be a deeper issue!

@support
Are we suppose to enable Multicasting (IGMP Proxy) or not? The Roon kb and support told me to enable it, and now support says to disable it? What is it, enable or disable?

norisRoon Labs: Support

17d

Hi @ToreB,

Have you made sure to enable Multicast Routing on the ASUS router as per our Networking Best Practices ?

– Noris

@Peter_Hancock
I have fixed my issue.

For anyone that experiences this issue, here is the rundown:

  • When updating the firmware, the amp said all was successful.
  • I did not check the actual display to confirm (pretty bad as I’m an auditor and as we say “in God we trust, all the rest we audit”)
  • After the update I had no RAAT zone in Roon
  • I discovered that I was running the latest firmware but DOS was still on version 2.1.0
  • I loaded the DOS version by entering the IP address of my Devialet in my browser, choosing the upgrade DOS option and attaching the single dos_xxxxx file from the latest firmware zip file
  • After the update the DOS version now displays as 2.2.4 and it also shows the wifi IP address
  • The Roon RAAT output immediately appeared in Roon
4 Likes

Followed your steps exactly Heine_Streicher. Problem solved. I am so grateful for this solution after hours of frustration and dead end advice. Thanks!

2 Likes