Export crashes Roon

Core Machine (Operating system/System info/Roon build number)

2018 Mac Mini / Mac Os 10.14.6 / Roon Core Server build 537

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired system / Unifi APs and Switches / Pfsense router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Combination of Sonos / Kef / Ropieee but this is not really relevant to the issue

Description Of Issue

I typically use the ‘Export’ function for consistency on my AK dap. So I may buy/rip a bunch of albums, drop them into Roon, let Roon match them and then I export them with all the lovely metadata.

Only with the latest build I simply cannot get it to export. It crashes every time (sometimes it exports a few tracks, at most one album – then crashes). The spinning progress indicator freezes and the whole application locks up. A force quit is the only way out. I have tried three different machines as well as rebooting the core, and out of desperation a complete hardware reset of the core machine.

This used to work perfectly so wonder if something has changed in the latest release.
Please help!

EDIT: It seems to be that if i export one album at a time it is OK, but will consistently crash if exporting a bulk list of various albums

Hello @Philip_Dall,

Could you please attempt to export the albums again and reply here with a timestamp (your local time) when you do? I’d like to enable diagnostics for your account and bring this information to my team for further investigation. Thanks!

Sure, just tried again. Crashed at 6:37AM Singapore time.

Hello @Philip_Dall, what remote were you using when you saw this crash?

Roon for MacOs, latest build.

Same issue for me…

10:10pm Sydney time… OSX client
1.7. BUILD 537 stable

Hello @Philip_Dall,

I enabled diagnostics on the core and discussed with our team a moment ago. They have asked me to do the same for the MacOS device but the core detected multiple similar devices.

Could you please reproduce the issue one more time and use the directions found here and send us over a set of logs using this link. This will give me logs from the correct machine, thanks!

Sure, I have shared logs for both the client and server. I didn’t go all the way back in time (there were loads), just the last two log files for each.

Let me know if you need anything else.

Hello @Philip_Dall, thanks for your patience! I wanted to keep you updated on our progress for this issue. Our development staff is currently investigating the logs you provided and we should be in touch soon. Thanks!

Any update to this?

I just noticed the same issue on my mac, used to work for my nearly 700 tracks playlist.

Yeah, would have been nice if this was included in todays update… I’ve tried on four systems, all have the same issue.

Hello @Philip_Dall, we appreciate your continued patience in this matter while we investigate the issue. I just wanted to drop in and let you know that this issue is still on our radar and we are working towards a solution.

Thanks :slight_smile:

A post was split to a new topic: Exporting crashes Roon

Any update on this Roon? I have been waiting 3 months for a fix…

Hey @Philip_Dall,

I wanted to touch base with some good news, which is that our technical team has been able to reproduce this behavior and we’ve opened up a bug report with our developers.

While I can’t say for certain when this bug will be fixed, getting things reproduced in-house is a critical first step, and I will keep this thread up to date as the team passes along feedback and work begins to get this resolved. Thanks again for the report!

Any word on this??? I can’t export more than a single album, or 2 at most, from either MacBook or iMac without Roon crashing hard, requiring a force quit.

Well I’m glad you managed to recreate the issue! As I and others have pointed out, all you need to do is install roon on a mac and try and export more than two albums :rofl:

I have tried multiple different cores, ROCK, RoonServer, Different OS versions (10.14/10.15).
They all crash it.

Most annoying of all, is this was never an issue previously and I can find no way to downgrade.

Eagerly awaiting a fix :slight_smile:

Well, this needs swift addressing. Same issue here, but i cannot export ONE album either, crashes without a doubt.