Export To Excel Not Working

Well - I just tried it on a Mac and it does not work.
I import the file into Excel (for Mac) and I am told there is something wrong with the file.
I also tried to import it into online Google Doc’s and was greeted with the same thing.

I tried exporting twice and both times it did not work

@Gregg_Levethan Glad to hear I’m not the only one. Hoping that @danny will fix this and just make a Print to PDF and be done.

I think you’ll find that Excel is just giving you a warning, but that you can go ahead and open it. If I open an Excel export file from Roon in Excel on Windows, this is what I see:

I just click on “Yes”, and the file opens to reveal the exported data. I can then use Excel to print this to a PDF in Windows.

Yeah that doesn’t work and don’t forget I’m using Mac…which is Numbers. Print to PDF - problem solved on all platforms.

I take it that Numbers can’t really deal with all versions of Excel files then? That’s an issue for Apple to deal with, it seems to me.

And as for implementing a “Print to PDF” function - easier said than done, I suspect. Not for nothing is this function handled by the operating system in Windows.


If you install Libre Office on your Mac it will open up the file just fine, exactly like Excel on a PC does (no error messages on Windows for me).


Numbers doesn’t give me any error messages just opens up an XML type view of the file which is less than useful.

Thank you for the suggestion of Libre Office however I would prefer not to download yet another program onto my Mac - especially considering I own an official copy of Excel

Attn ROON @support

I maintain that this is a problem with ROON running under OS X. I surmise the problem may be that ROON saves this file in an older unsupported version of Excel. It is also possible that the operation of exporting an Excel file works correctly under ROON running in Windows but not ROON running in OS X.

I have a Microsoft OneDrive account and subscription to Office and Office Online. I also have Excel running on my iOS devices. In all instances I am receiving the error from Microsoft’s programs that the file is unsupported - or an older version of Excel no longer supported. Either way official Microsoft Excel programs do not open this file so I will maintain that this is something ROON needs to look into on their end. Once again it may be a problem unique to ROON under OS X .

I am new to ROON so I am not sure how responsive they are on this board - do they actively monitor it??

Thanks for the additional info. The Excel file produced by the Roon export process is supposed to be compatible with older Excel formats (Excel 97 - 2003), but clearly there is something odd about it that causes it to choke in the Mac and OneDrive versions of Excel…

Paging @support - could someone take a look at this export process, please - I think there is a bug here…

Hey @Gregg_Levethan – we’ll take a look. If we can reproduce the problem, we’ll open a bug ticket in our internal tracker and get this fixed.

If we cannot reproduce, we’ll need to gather some more information from you – stand by, and thanks for the report!

I can confirm that Libre does indeed work.

Follow up to this (and also posted on a similar thread)

I had another go with this (ROON core running on an iMac) and I think the problem is that the file outputted by ROON is a .XLS file while current Excel files need to be .XLXS in order to open in Excel for Mac (or even in Numbers).

So in reality it is not new functionality which is needed but rather a proper file format.

There is another thread with this same issue so I will also post this there as well

The exported file from Roon is in XML format that is support by MS Excel on Windows (but it seems may not be on the Mac version of Excel. If you open the export file in a text file edit you can see it plain text XML.

You could try changing the file extension from .xls to .xlsx but I don’t it will make any difference.

(I’m cross-posting from the other thread. Apologies for the protocol breach, but in this instance it seemed warranted.)

I just had some time to investigate the “can’t open the Roon-generated Excel file on a Mac” issue, and I can open the “.xls” file generated by Roon in Excel for Mac 2011 (v14.7.5).

I think I figured out the problem with Numbers: Even though the file generated by Roon has a “.xls” suffix, it’s appears to be what Microsoft calls an “Excel 2004 XML Spreadsheet (.xml)”, as @Carl notes. So the file should really have a “.xml” suffix, and indeed, if I change the suffix to .xml, Excel for Mac can open it with no problem … but Numbers can’t. If, OTOH, I resave the Roon-generated file out of Excel for Mac as a “real” .xls file, Numbers can open it!

So while I realize that the “.xml” file is supposed to be the “open” solution from Microsoft, in practical terms, for Win-Mac compatibility, it’s probably best if Roon would generate a more standard .xls file, one that Numbers can open.

I tried using Microsoft’s Open XML Converter (which appears not to be available from Microsoft any longer but is available from various download sites) to convert the Roon-generated file, but regardless of what suffix I used, and even if I resaved the Roon-generated file out of Excel as a “.xml” file, the converter would not recognize the file as something it could open, so I’m clearly not on the same page with Msoft, but nothing new there.