Extension manager dissapearing


(J. V.) #1

Hello,

I’m testing the extension manager and the alarm clock extension. I like both ideas very much, but i have an issue.

my roon core runs on a QNAP TS-253be and works perfectly.
first i tried to install the docker qnap image for the extension manager, and after setting up and running the extension manager, the extension manager is visible and i can enable the alarms, and everythin works. However, after certain time (don’t now exactly when) the extension manager and configured extensions have dissapeared.
and i have to restart the docker and extension manager in the docker to get it working again.

i also tested the extension manager on 2 raspberry pi’s: same issue: at first when i run the extension manager via ssh on the pi, the extension manager becomes visible, and i can enable the alarms, and all works fine. but again, after certain time everything dissapears. when i ssh into the pi and restart the extension manager, it’s working again

am i missing something here?


#2

Hello @goat,

Did you follow the instructions given in … ?

Additional informations can be found here.

The --restart unless-stopped option should take care of restarting the docker container if needed. Unfortunately, the GUI of QNAP doesn’t offer the possibility to set this parameter in this way.
You can use the shell (Shell App or SSH) to run the command docker run -d --network host --restart unless-stopped --name roon-extension-manager --hostname Docker -v roon-extensions:/root/.RoonExtensions/lib -e "TZ=<timezone>" theappgineer/roon-extension-manager:latest or use ContainerStation > Create > + Create Application, which is how I did it, and then provide a docker compose configuration that does basically the same. For both cases, make sure you provide the correct time zone for the alarm clock to work correctly!

Here’s my docker compose configuration for reference:

version: '3'
services:
  roon:
    image: theappgineer/roon-extension-manager:latest
    container_name: roon-extension-manager
    restart: unless-stopped
    volumes:
      - roon-extensions:/root/.RoonExtensions/lib
    environment:
      - TZ=<timezone>
    network_mode: host
volumes:
  roon-extensions:
    external: true

Make sure you open up the extension manager in Roon and do a manual update to ensure you’re running the latest version. Now it should run without further issues – at least it does for me – on your QNAP NAS.

Hope this helps.


Roon Extension: Alarm Clock v0.7.4
Schedule Alarm Clock to start Internet Radio
How to: Install Roon Extension Manager on QNAP
(Jan Koudijs) #3

Have you used the setup script for installation? This configures a service that takes care of the restart after e.g. an update cycle.


(J. V.) #4

Jan,

no i followed the manual instructions which were described for dietpi

I now ran the setup script, which ran correctly and which has setup the extension service
looking good now

now i’ll wait and see if it remains visible

thanks for pointing me to the setup script!


(J. V.) #5

setup script for raspberry pi works like a charm!

alarm clocks everywhere now :smile:


(J. V.) #6

hmm

i’ll try this in the docker later on

at the moment it’s running perfectly fine on the raspberry


(Jan Koudijs) #7

That’s a pity. Is the restart the only option that cannot be set via the GUI?


#8

Yes, it’s the only one.





Auto start: here in the meaning of start this docker application automatically when ContainerStation gets started (normally after a reboot of the NAS).

But using one of the above mentioned methods (Shell or Docker compose) will not make the QNAP management solution ContainerStation obsolete. The application is shown and also manageable just the same as it would be when setup through the GUI.


Detail view:

A subsequent change of the settings is not necessary but possible.

Don’t let you fool by the Auto start: slider in Off position. It’s not needed to set to on. Docker itself will preserve the current running status beyond reboots.


#9

I’ve actualized my Docker Compose:

version: '3'
services:
  roon:
    image: theappgineer/roon-extension-manager:latest
    container_name: roon-extension-manager
    restart: unless-stopped
    volumes:
      - roon-extensions:/root/.RoonExtensions/lib
      - /var/run/docker.sock:/var/run/docker.sock
    environment:
      - TZ=<timezone>
    network_mode: host
    hostname: Docker
volumes:
  roon-extensions:
    external: true

Roon Extension: Alarm Clock v0.7.4