External source controls no longer show after version 1.8 upgrade [Resolved with Build 763]

Also have the same issue. More than one source doesn’t show.

Mike

1 Like

Hi @peter_richardson & @MorrMusic ,

Thanks for the additional confirmation. Would you be able to please provide a set of reproduction steps that I can pass on to QA regarding this issue? Which extensions / devices are needed to reproduce this in the lab? Please let me know when possible, thanks!

Hi @noris,
It’s super easy to reproduce this issue. Simply have 2 or more extensions which implement the source-control and they are setup to support standby mode.
Then enable all of them in ‘Zone Settings → Device Setup → External source controls’.

Once they are in and user tries to click on the standby button, the menu opens up a bit (same like in 1.7), but we only get a blank area with no buttons.
Previously in 1.7 we had in this blank area a standby button for each enabled source control.
Peter has already provided several screenshots so if this is shown to the developers, it should be very clear to them.

This issue happens on all remotes I’ve tried:
Windows, iPhone, iPad, Android phone

2 Likes

Thanks for so elegantly demonstrating the issue and how it can be simply replicated. I already provided the code for a basic extension that creates two source controls attached to an output.

This should be enough to pass on and I can either put on git hub or share directly if the forum post is not adequate (I can’t seem to be able upload a script file to a forum post)

@StefanK , @peter_richardson , thank you for your detailed descriptions of this issue, I was able to reproduce this and put a ticket in for our dev team.

Thanks!


Ivan

3 Likes

Not getting any resolution to this so starting a new thread please put it where it belongs but CAN I HAVE A SOLUTION a please? Every day - yes every day since 1.8 I have to restart the core to get the audio end points recognised. There is a Dac which always used to work and more recently 3 raspberry pi 4 with hats. Have restart the core and go into audio settings and disable and enable to use them - every day. When can I have a fix , for the love of god. Running it from a qnap nas. Happy to dig up more details if I can get anyone to answer me . Pleeese. Pete

I’ve had this problem too @pete_keeley. It’s not every endpoint, but many of them. Roon is aware of the problem. I’m sure it will get fixed, but Roon almost never posts a time estimate.

1 Like

Hi @pete_keeley,

I shifted your post here as I understand this is the issue you are referring to. If so it has been reproduced and a ticket opened for a fix.

1 Like

Thank you very much, glad it is being looked at. Sticking with Spotify over airplay (sadly) for now

Thanks for letting me know good to hear someone is working on this. I am losing all endpoints until I reboot the core so no music at all. Will sit on my hands for a week at hope for the best

Just reading this I don’t think this is the issue I raised and has been reproduced. That is only a problem with extensions that use multiple external source controls.

It may be helpful to provide more details on what you are observing.

Rebooting certainly has no effect on the above.

I do hope it can be sorted out for you and doesn’t require extensive work before you get back the functionality you need.

1 Like

Thanks I will findtime to report this more fully with screen shots and specs. Currently I can’t play anymore.
13 meetings tomorrow- need to focus to give some more detailed feedback. Meant to be listening to music to relax. Ho hum - at least the turntable is unaffected

I am experiencing the same problem but I am using a single external source control in the audio device.

image

Thanks - I see that you are using the Deep Harmony extension. That uses a similar approach to the code that has given me issues and I think allows multiple source controls to be attached to an output (I don’t have their source code to look at). I’ve not seen anyone else reporting with this extension - which has surprised me. Anything unusual in the way you have it set up? Anyone else using Deep Harmony having a problem?

Roon team - any update on progress with this?

This has been resolved with the release of build 763.

Thank you for the prompt response.

1 Like

This has only been resolved for Windows . When I use android or IOS the problem remains - but they have not updated to the same build - I assume these will this be corrected with updates to these interfaces too when available from respective app stores?

Now confirmed available and working.

Thanks again.

1 Like

It works now :+1:
Tested on iPhone, iPad, Windows and Android (apk version).
Core and all clients need to be updated to the latest version (build 763)

Thank you Roon team

1 Like

Hello All,

I wanted to reach out and let you know that we released Roon 1.8 / Build 763, which includes some improvements that we believe should help here. Please give the update a try and let us know if it helps!

You can read the full release notes here:

Thanks,
Roon Support

Thank you. This has fixed the issue.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.