External USB not appearing (formatted as ExFAT)

Core Machine (Operating system/System info/Roon build number)

NUC i5 Roon Optimized Core Kit (latest update as of 2/8/20)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

I have an external USB drive. It was formatted in Mac OS Extended. I plugged it into the NUC. Roon read in all of the content, no problem. Everything is great! Then I realized that Roon can’t write to drive (I hadn’t read the ExFAT note). So I removed the drive from NUC, reformatted as ExFAT on my Mac, copied the music back over to it. When I plug the drive into my windows laptop or my Mac, it is seen and all the music is there. When I plug it into the NUC, the drive does not appear to mount. Tried plugging in and rebooting, no joy. Here are some screenshots with additional detail. Any ideas/suggestions?

Hi @Jim_Willis,

Have you tried using a different USB cable?

Can you share a screenshot of the Web UI?

Hi @Jim_Willis

I am not 100% sure about this but on the drives I have formatted as ExFat through Disk Utility I have had a disc under the top level (I don’t know the correct technical term for it, perhaps someone with more knowledge can step up) but this works for me. The top level has to be “Master Boot Record” and you need to select this when you format the disc. Please see my attached images.

This image explains it a lot better than my non-technical terms can:

@oneofmany Huge Thanks!!! I couldn’t view the “Scheme” in disk utility without going to the “view” menu and select “view all devices.” Once I did that I was able to select Master Boot Record for the scheme which I suspect will solve the problem here (will report back later today after all of the music copies over. again.

1 Like

Changed the boot record scheme didn’t solve the problem, the drive still isn’t seen by Roon but it seen by a windows laptop and an iMac. I’m going to guess there is something flakey with the drive. Another SSD that I have works just fine so I’ll use that instead. Appreciate the feedback/help here.

1 Like

Bugger, sorry about that @Jim_Willis I hope support help you get it sorted out.

Hi @Jim_Willis,

Can you share a screenshot of the Web UI?

What is the model of the drive?

it is a seagate 500GB USB drive. not sure of model #.

Hi @Jim_Willis,

Moving forward can you please try the following:

  1. Unplug the device
  2. Reboot ROCK
  3. Once ROCK starts up, connect the USB drive and make a note of the time you do this

Respond here with the time in your local timezone from step 3 and we’ll enable diagnostics.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.