Extreme delay when selecting new track

I’ve been using Roon with my Innuos Zenith dedicated server (via the “experimental” Squeezebox option) and controlling with with a MacBook enthusiastically and without issue for a few months now. About two weeks ago, I suddenly was unable to play or switch tracks without a 20-30 second delay, as though the whole track were being buffered. About one in five times, newly selected tracks will play immediately as before without issue, and about one in five times nothing will play without rebooting. This all started BEFORE I updated the MacOS to the latest Catalina and Roon to the most recent version. Updates resulted in no change. I feel as though some switch was toggled inadvertently somewhere. Any insights would be greatly appreciated! Thank you in advance!!

Hi @Jason_Duggan,

Can you describe your networking setup? Was there any change in your network around the time this started happening?

Does Roon behave the same, when you restart the server?

Also what core machine and os are you using…there were updates for Catalina around about 2-3 weeks back.

From my AT&T router, an ethernet cable to Innuos Server. No network changes. Roon behaves the same when server is rebooted. Software updated this week to OS 10.15.1., Roon is 1.6. Ugh so frustrating!!

Also I suppose it’s worth noting (forgot to mention) that I only stream music via Qobuz, no library.

Hi @Jason_Duggan,

If possible, it would be a good test to try streaming any local content from instead of Qobuz (even if it’s just a test file) and see if the same behavior occurs.

Also, as a test, it would be good to know if the same behavior occurs if you use the MacBook as your Core instead of the Innuos.


I had something similar a while back when I used Roon on my Innuos. I found that changing the DNS server settings of my LAN (on my router) to using public ones (such as Google’s DNS servers - For IPv4: and/or pretty much alleviated the issue.

Hope this may help.




I tried joining TIDAL again, and it works, but I’m still having the frequent and extended lag between tracks on Qobuz though. I’ll see if I can figure out how to change the DNS server settings of my LAN, but that may be beyond my skillset…

Hi @Jason_Duggan,

Using Google DNS is definitely a good suggestion — We’ve seen this help similar reports. You can read more about Google DNS here:

Thank you for the great help!! As it turns out, AT&T routers are hard wired and will not allow changing of the DNS. AT&T recommends either (1) adding an additional router (would rather not) downstream that allows it or (2) changing DNS at each individual device. I have an ethernet switch between my AT&T router and my Innuos Zenith server. Does anyone think I could change the DNS at just one of these points to allow the desired effects? My MacBook serves as Roon Controller.

You need to change the dns setting and likely use a fixed IP address on your roon core. Doing a fixed ip address might mean finding a spare ip in the router non dhcp range or making a reservation within the range for that device.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.