Fail to Launch, Corrupt DB/Backups, failure to find audio devices

Roon Core Machine

Proxmox Ubuntu 18.04 VM (8 core, 28GB RAM)

Networking Gear & Setup Details

Unifi Networking, Pfsense firewall, Edgerouter, all wired with 10G or 1G ethernet.

Connected Audio Devices

Anthem STR → USB → dietpi allo → ethernet → roon server

Library Size

DB folder is ~7GB? Backups folder seems to be around 50+ GB

Description of Issue

  • All was working a couple weeks ago when I last used roon with no issues.
  • 2 weeks ago a transferred all my data to a new NAS. This means that roon has a link to an old smb share that now does not exist (nothing exists at that IP actually)
  • The roon server prints the following nearly constantly
CIFS VFS: Error connecting to socker. Aborting operation.
CIFS VFS: cifs_mount failed w/return code = -2
  • That error makes sense given the change of NAS. However I was unable to get any Roon GUI’s to launch. They would just sit at the roon logo forever.
  • I tried to reinstall RoonServer following the instructions here: I used the easy installer.
  • After the re-install I was able to get it to launch but there were no audio devices available
  • I proceeded to restore from the latest backup
  • Backup failed around 50% complaining of a corrupt backup
  • I renamed the all the folders in /var/roon/ to force them to be regenerated
  • Saw roon was a clean slate
  • I tried to restore the earliest backup in history (roughly a month old) it also failed around the same place
  • Out of desperation I picked a third backup at random from the list of backups and it restored fine
  • Was able to launch and change the SMB paths
  • I started making a new backup

The question is if I keep making backups of my db is there a chance my whole db is just corrupt and I just got lucky on the restore the third time (literally third time’s the charm) or is it more likely 2/10 backups were just bad and I just happened to pick a good one this time? Is there a way to verify my db?

Hi @Matt_Lathrop, sorry for the trouble here!

If you were able to restore the backup you should be good moving forward. The prior two backups you tried were likely corrupt as well, but once restored things should work from there.

What I would recommend, though, is checking the RAM and SSD of the Core and make sure that they’re not potentially failing. Hardware failure is the most common cause of corruption, so definitely good to check on that.