Failed to initialize audio device - Roon core on iMac

Roon Core Machine

Mac OS x 13.1
iMac Retina 5k 27" 8 core i9 64GB RAM

Networking Gear & Setup Details

DAC connected via USB to Roon core hosted on iMac

Connected Audio Devices

DAC Cambridge DACMAGIC 200M connected to iMac with QED reference high resolution USB cable

Number of Tracks in Library

No music Library, only Tidal streaming music

Description of Issue

I’m trying Roon and I have to decide soon if purchase a yearly plan or give up.
I often get an annoying “failed to initialize audio device” popup message. When it happens, I select again the correct audio zone, then everything seems fine, but the issue occurs again after few tracks. The DAC I’m using is Roon certified.
No issues with other SW (e.g. Audirvana and native Tidal app).
I tried to install Roon core on Synology NAS, no way, same issue

Hi Marco, fellow users here
Do you use 200M only with Roon? Check if exclusive mode is selected. Might also be some Ventura issues. There are some people getting hard times with Ventura and USB DACs.
I have a m1 mini with 13.2 and usb to 200M, nothing like you describe.

Hi Traian. Exclusive mode selected

Does this happen when there is a change in sample rate? if on a playlist with different files (mqas and flacs, 44.1 or etc)

I don’t know

hi, sorry for the delay

here is a link but have a read before kill core audio

Might be your problem or not be. sorry for your troubles

Thank you Traian, this might be the cause.
Until all the issues with Mac OS will not be cleared I will not be able to continue my subscription to Roon

I know Marco, I understand… sometimes is like a draw of the straw… some Macs work perfectly some not… usually the latest ones have problems but when you want support always the first is question “are you on the latest software”
All the best


I have the same issue (with a FIIO K9 PRO). Only on IMAC…
Any solutions?


Some things to try, I do not know if it will work. Looks like for some people is easy for other not.
In the last week happened to me once. Restarted all (router, switch, Roon Core computer, Roon Remote computer, Bridge device (and Dac) and the issue did not reappear

Might try:

  • Before doing anything, create a Backup of your Roon database and save it somewhere safe
  • Delete roon cache
  • Rebuild RAAt server
  • A fresh install:
    • Create a Backup of your current database
    • Exit out of Roon
    • Navigate to your Roon Database Location
    • Find the folder that says “Roon”
    • Rename the “Roon” folder to “Roon_old”
    • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
    • Verify if the issue persists on a fresh database before restoring the backup
  • Kill core audio

Already did all of these. Not working. Still a problem.
I tried, also, with Audirvana. Same issue…
Ventura issue or…DAC (FIIO K9PRO).
Still inclining to Ventura, since FIIO (with a Windows, IPAD - with ROON) works in every setup (stress test - cable disconnect, move to bluetooth etc).


Dear Traian. I followed your suggestion with a fresh reinstall + killing core audio and… it seems to work now. In the weekend I will go on with tests and if everything will be solved I will offer you a dinner next time you’ll be in Milan. Thank you

1 Like

Marco I just hope it will work.
If I in Milan or you in Bucharest dinner is on the table.

Also think it is Ventura.
I guess stupid question but firmware upgrades for K9PRO? Or could try a roon bridge device or a USB>SPDIF converter. Frustrating problems.
But Ventura can use the K9PRO? (from system prefs)

Updates only for the one with AKM chipset.
Roon bridge…yeah. that might work.
USB to SPDIF …oh…
Yes - it can use. Actually - if I select in ROON system output instead of FIIO, it works flawlessly. However, I can’t change some parameters (this way).

Oh I did not notice there are more versions than the one with AKM

Another dumb question, are you using an USB hub? Or if you have one maybe try. Or an USB C to USB A adaptor. I had MQA problems with shutterings when USB from core, never found a solution (Zen Stream was the solution and worked until me using MQA full decode in roon). I think at that time I was using an USB C OTG to USB A 3.0 and after that the usual cable. Also some people having this problem with MBPs did use a powered USB Hub. And sometimes the fancy USB cables can cause problems.
Hope you will find a way.

No - direct connection (no hub).
Thank you for the support.
One way could be…Audirvana :).

Will see.
Roon seems to not manage to keep up with Apple dev.

Or it is not the no 1 to do in their list :slight_smile:

Also you can try HQP to see if it is failing to initialise the dac

Here is the Apple dev reply:

Engineering has provided the following information regarding this issue:

It appears that the issue is at the USB layer:

| | | | | “port-statistics” = {“kPortStatEOF2ViolationCurrentConnectCount”=0,“kPortStatEOF2ViolationDuringResetCount”=0,“kPortStatPowerStateTime”={“kPowerStateOff”=“0ms (0%)”,“kPowerStateSleep”=“8976ms (0%)”,“kPowerStateOn”=“36964567ms (38%)”,“kPowerStateSuspended”=“60142664ms (61%)”},“kPortStatConnectCount”=27,“kPortStatRemoteWakeCount”=0,“kPortStatEOF2ViolationRecoveryDuringResetCount”=0,“kPortStatAddressFailureCount”=6,“kPortStatEOF2ViolationCount”=0,“kPortStatEnumerationFailureCount”=12,“kPortStatOverCurrentCount”=0,“kPortStatEOF2ViolationDuringResumeCount”=0}

Restarting the DAC recovers, so it seems the device is malfunctioning. We don’t see evidence of a problem in the host transport stack.

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.