Failed to open audio device: NUC7 with Roon ROCK,

Core Machine (Operating system/System info/Roon build number)

Intel NUC7 with Roon ROCK , and wired portable hard drive storage.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

NUC wired into D-Link DAP-1650, wirelessly connected to Apple Time Machine. Arris SB6183 router and TM 822modem

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Marantz AV7005 with USB connection to NUC

*Description Of Issue

Room remotes see files in my database, and ROCK can be operated via web browser, but “Failed to open the audio device” appears whenever I try to play something. 2+ years with same setup and no issue before. Tried restarting Roon server software, reinstalling OS, and swapping hard drive library with another. Still fails to open.

Can you help? Sheltering in place without music...

Hi @RichardB,

Welcome to the forum!

Have you tried a different USB cable connecting to the Marantz yet? Sometimes cables go bad, so I would verify this as the starting point.

Why is it showing 2 IP addresses for the web UI?

Thank you for your replies. I figured out what causes the “Failure to connect…” error message. It’s not the cable, an HDMI from NUC to AV preamp/tuner, which works fine.

I forgot to mention that I have a Roon-Ready HiFiBerry DAC+, to extend my Roon into a guest room, for occasional use. When I disabled the HiFiBerry, the main setup worked fine. I’ll have to look into why the HiFiBerry no longer connects — maybe a software-update issue.

Hi @Richarrd_Bookwalter,

I’m not quite sure where the HDMI comes in, was this a separate connection than the USB?

It sounds like you might have both WiFi and Ethernet connections active on this NUC. If you not using the WiFi module, you can disable this via the WebUI.

That’s interesting. The HiFiBerry connected to a different audio endpoint and you’re saying that with this HiFiBerry zone active your USB Marantz zone does not work as expected?

The WiFi operated the HiFiBerry, and the wired connection operated the NUC. Until the other day, when the HiFiBerry stopped connecting, and prevented the NUC from connecting, too. disabling the HIFiBerry re-enabled the NUC.

You assumed a USB connection. There is no USB connection: the NUC connects to the AV via HDMI.

I think that the following from your original post may have confused things…

1 Like

Sorry! My mistake. HDMI, not USB.


Hi @RichardB,

Thanks for the clarification.
Has the system remained stable since resetting your HiFiBerry zone?

Resetting did not work, but I was able to fix the problem by purchasing a new microSD card, downloading the latest HiFiBerry version, and restarting the system. It’s possible that the old SD card failed, since I wasn’t able to erase it and rewrite it with the image of the new software.
The guy at the store, where I bought the new SD card, was wearing a gas mask like this one, to avoid COVID-19, so it felt like an adventure.

Thank you everyone for your interest.

1 Like

That’s fantastic news @RichardB, glad to hear the new SD card resolved the issues you were facing!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.