Failed to sync sender clock to endpoint & Roon fails to play any music on local outputs connected to the core [Solved: Disable VPN]

Core Machine

Windows 10
ROG Strix X570-E MB
AMD Ryzen 7 3800X

Network Details

Ethernet, some old Netgear switch, basic Comcast router. (Nonissue. This problem is happening when playing music from the Roon Core machine itself.)

Audio Devices


Library Size

20,000 tracks

Description of Issue

A constant cycle of failing to sync the clock and giving up. This happens no matter what output is used. DAC itself is not the issue as far as I am aware; works with Foobar, Tidal app, Qobuz app, etc.

05/30 15:43:04 Warn: [SMSL] [zoneplayer/raat] failed to sync sender clock to endpointSMSL USB AUDIO: Sooloos.Broker.Transport.ClockSyncResult

05/30 15:43:04 Warn: [SMSL] [zoneplayer/raat] failed to sync clocks with any up

Hello @Adam_Harrison,

Welcome to the Roon labs community :wave: (9 days too late…)

I am very sorry we took this long to get back to you :pleading_face:

I was wondering, are you still running into this error still? If so, we’d really like to take the chance to help :nerd_face:

Please, let us know :pray:

Hi, I’m having the same error

Hi, I found a solution to this problem.
In my case, I exchanged my faulty M500 for a new one and Windows and all my other apps were fine with it except Roon. I figured it had something to do with zones configuration.

I made a backup of my Roon DB just in case. Closed my Roon server instance.
I deleted all files (up from a certain date, my original M500 purchase date) from the directory:
AppData\Local\RoonServer\Database\Core\< ID >\transport\

Upon restarting Roon, it took it just a tad while longer, but everything worked perfectly as expected.

Thanks for weighing in @grzlybear! That’s really helpful. @Adam_Harrison good you give grzlybear’s suggestion a try?

Ok, sorry to say that I’m back at square one.
The problem has returned.

My M500 works perfectly with other WASAPI applications such as foobar.
I even reinstalled my entire Core, with no change.

I’m at a loss here. What else is there to do?

Ok, tried hooking up my old Khadas Tone Board and the same thing happens!

Works perfectly with foobar but doesn’t work with Roon.

For a matter of fact, Roon fails to play any music on local outputs connected to the core. Even the onboard system audio doesn’t work.

Hey @grzlybear,

Could you please clarify? When trying to play to System Output, Roon still doesn’t play?

Exactly, roon won’t play on the System output or any USB dac connected to the core

Hey @grzlybear,

Thanks for clarifying right away. So sorry about the trouble. If you also do not see the audio devices in Settings → Services, could you please try this:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • (Optional) Restore Roon from a backup at least a week before this issue started

Thanks :pray:

I do see them, but when I try to initiate playback on one of the devices I get the same error reported in this thread.
From a UX standpoint, Roon behaves as if everything is in order and “start” playing the track. However, the track is skipped without a second of music being played and without any UI indication that there is a problem.

Hey @grzlybear,

Thanks a whole lot for following up.

I was wondering, if you try ASIO instead of WASAPI, does your M500 work?

nope, ASIO doesn’t work

I have a breakthrough!

The culprit is my VPN. I’ve been toying with split tunneling to allow Roon’s traffic to be excluded from the VPN. Most of the things worked fine and streaming to my ethernet connected rasberry pi worked fine. However, USB playing didn’t work.
Once I disabled the VPN everything works.



WOW! That is a breakthrough! SO amazing you thought of that.

While we do know that some VPN settings can interfere with Roon, I clearly did not consider that.

Thanks for sharing :pray:

1 Like