Failure to rip CDs and Slow Roon app on M1 Mac


Roon Core Machine

Roon Nucleus with no additional internal storage and latest software. Purchased a few weeks ago.

Networking Gear & Setup Details

Third Floor: The Roon Nucleus is connected by CAT6 Ethernet cable to a Luxul 12-port/8 PoE+ Gigabit Managed Switch model AMS-1208P. I have a M1 Mac Mini (2020, 8 GB, OS Monterey version 12.2.1) connected by ethernet to the switch.

Ground Floor: The managed switch is connected by CAT6 Ethernet cable to a Luxul 26-port/24 PoE+ Gigabit Managed Switch model AMS-2624P. This switch is plugged by CAT6 cable to a Xfinity xFI Gateway Router model name CGM4331COM by vendor Technicolor.

Connected Audio Devices

The 2 USB ports on the back of the Nucleus are used by my Amicool USB External DVD Drive (Amazon) and a Seagate 5 TB external desktop HDD model SRD0NF2.

The Roon remotes for DACs, Amps and Sonos speakers are an iPhone 13 Max and a 2019 12.9 inch iPad.

Number of Tracks in Library

5000+ tracks

Description of Issue

Problem 1. I’m having trouble ripping CDs. Please send me some advice.

I was successful ripping music files from a purchased CD on an Apple USB SuperDrive player plugged into the back of my Roon Nucleus. This USB CD/DVD player was the first I tried.

The CD’s contents were stored on the external HDD plugged into a USB port on the back of the Nucleus. After the successfully ripped CD was ejected and another CD was placed in the player, the Roon software didn’t recognize second CD. I rebooted the Nucleus without success.

I then replaced the Apple SuperDrive with the Amicool USB External Drive because this drive is Linux compatible. After rebooting the Nucleus a second time, the new CD’s music was ripped and stored. The cycle of failure to recognize a new CD then repeated itself.

Problem 2. The Mac mini consistently runs the Roon software moderately slowly and intermittently skips songs. The Roon software on the Mac no longer crashes after I installed the Roon Nucleus for use as the Roon Core. The M1 Mac Mini was my original Roon Core Machine before purchasing the Nucleus a few weeks ago.

What do you recommend?

Hey @Craig_Logan,

Thank you for reaching out to us with your questions. We’re sorry to hear that you’re having trouble but we’d be happy to help.

You can find more details on CD Ripping with Roon OS in this article from our Help Center. Please take a look!

From what you’re describing on your M1 Mac Mini you may not have optimized it for Remote use after migrating your Core. Please take a look at the Previous Roon Core section of this article to do that.

If that doesn’t seem to help you can uninstall Roon completely from that machine and reinstall it, choosing to use the new install as a remote when prompted. You may also want to ensure that you’ve set Firewall Exceptions for Roon on that machine.

Please let us know if this helps, we’ll be watching for your reply.

Thanks so much. I’ll try it.

1 Like

I tried your advice. The article recommended renaming or deleting the database on your original Roon Core. My original Roon Core was my M1 Mac Mini.

I followed the steps and dropped the Roon database file in the trash can on my M1 Mac Mini. The file respawned before my eyes after dropping it in the trash. I renamed the database file with the same outcome. I tried both tactics multiple times only to see the database file pop back up in my Roon folder a few seconds later. Any suggestions?

Well, I would do this when Roon is not running. So, shut down Roon. Rename or Delete the database. Start Roon again and it will be like a fresh install and you then have the option of choosing to “Find My Roon Core” which will then let you select the Nucleus as the Core.

If you look at the location after doing the above, you will see that Roon will recreate the database if it senses that it is missing. However, it is a new database, not the old one, since that was deleted.

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.