Fiio M15 DAC Roon Rock

Hello, I have a Prime Mini 5 with RoonRock, I have attached the Fiio M15 as DAC via USB, unfortunately no music is played, what is the problem?

Might be incompatible with USB3 ports on Linux:

Hello, I have a USB 2.0 on the Prime Mini 5 and the Dac is also recognized but the music is not played

Are you using USBC-USBC or USBA-USBC I dont think ROCK/Nucleus supports USBC connection at the Core end. Update it might not matter as neither worked on my M11 either.

Update - I just tried my M11 on Rock and Nucleus and nothing showing up but I’m my client Mac no issue.
You do have to put the FiiO in USB DAC mode

I use USB A to USB C and I have switched the Fiio to Dac mode, it is displayed 768 / 1bit but no music is played, it is only displayed very briefly in Roon, then it jumps to the next trac

If you try it on your remote PC/Mac does it get seen and play ok?

Yes, the Fiio works as a Dac on my Mac Mini

Hi @Rolf_Kafka,

We were able to use our Fiio device on ROCK when activating USB mode on it, Settings -> Audio -> USB Mode -> USB DAC Mode. We used a USB 3.0A -> USB C cable to perform the test. I would try to reboot ROCK and use another USB cable/port to see if that helps.

Hello
Do you have testet on a Roon Nucleus PC ?

Hi @Rolf_Kafka,

Both Nucleus and ROCK run Roon Operating System, there should be very little difference between the results of this test from ROCK to Nucleus.

Ok thank you I’ll let you know if it worked

Hello I have now tested 3 usb cables with the Fiio, but it does not work as a Dac. It only shows 768mhz1bit, the music will not play

I have the same problem with my Fiio M15. I can’t reproduce anything. Previously I could use it without any problem with my ROCK, but now it only appears 768kHz / 1bit on the DAP screen.

I thought it could be the cable, but I tried it with a Nuprime Hi-mDAC and it plays the music without any problems.

I imagine it must be some problem updating the ROCK, since before if it worked, also the Fiio M15 works on my PC and is recognized as a DAC by Roon and plays music normally.

Hello everyone,

Apologies for any confusion, our QA testing as referenced by Noris was done with a different Fiio device.

Research suggests that the M15 has issues with Linux USB hosts, as noted by @BlackJack

Might be incompatible with USB3 ports on Linux:
https://www.head-fi.org/threads/fiio-m15-audio-player-dual-ak4499eq-7490-mah-battery-64-gb-rom-1299-99.920276/page-147#post-15610786

Roon Rock uses the industry standard UAC2 USB Audio protocol to communicate with audio devices. It’s likely that Fiio will need to update this device to work with UAC2 USB hosts for this to work.

-John

Hello, I’ve tried my USB 2 port and it doesn’t work on this either