FiiO M9 configured as DAC not initialized by Roon

Core Machine
Win 10 Home, intel i5, 8gb ram, Roon 1.6 Build 416

Network Details
Have not tried streaming over network yet

Audio Devices
FiiO M9 DAP configured as a DAC connected to core PC via USB

Description of problem
Roon seems to recognize the M9 but when selected it responds “failed to initialize audio device” I can use the system and listen to headphones attached to the FiiO as DAC but here’s the path:

The FiiO can play dsd128 natively, so how can I get Roon to recognize it?

Thanks! - Jack W.

PS: My AudioEngine A2+ speakers are recognized by Roon and it’s DAC plays when I attach it via USB.

The FiiO can play dsd128 natively internally but when use as external DAC, it requires Fiio ASIO driver to support native DSD. Try enabling Fiio ASIO driver. You have set whether Native or DoP.

Hi @JACK_WILLIAMS,

From the screenshot it appears that you are using the System Output, which is the using the Core’s internal audio mixer to output to the DAC. I would give the ASIO or WASAPI driver a try, and you can switch to it by selecting a different Zone from the bottom right. You may also need to configure the zone for DSD playback, which you can access by right-clicking the zone (in the zone picker button but before you open all the zones) and go to Device Setup to configure the DSD options.

Thanks, but I uninstalled the Fiio USB DAC driver and reinstalled the FiiO_USB_DAC_Driver-V4.47.0, and restarted Roon. Got this under audio:
image
When I enabled the Fiio M Series, it was not recognized as playing after selecting it. FiiO doesn’t seem to have a separate ASIO driver, so I downloaded the ASIO4ALL_2_14 and it was no help. Device manage says the driver for the FiiO M is fiio-usbaudio.sys and when updated, says it is the latest. So I’m scratching my head and will contact FiiO also.

Uninstall all drivers then install FiiO_USB_DAC_Driver-V4.47.0 ONLY. Enable only the ‘Fiio ASIO driver’ at the bottom. Disabled all the rest.

Interesting – I disabled all but the ASIO and got nothing. Then disabled all but the FiiO M Series WASAPI and now it’s playing with the end point being the FiiO. So thanks for your suggestion and time !

What other music players did you have on that machine? And were you able to switch to any of them and play OK? ASIO drivers try to take control of the playback device but are often unable to do so if another program has control.

Hi @JACK_WILLIAMS,

Glad to hear that the WASAPI drivers are now properly working for you!

This is also a possibility here, if you are by any chance using other music streaming apps to the DAC at the same time as Roon it can cause a conflict since the app may be using Exclusive Mode and I would double check to make sure this is not the case.

Good idea about other apps conflicting, but Roon was the only one running through it. As a coda, I attached a Monoprice Monolith headphone AMP/DAC (desktop) to my Roon core PC and it worked only after disabling all other audio devices! Now onto a networked PC running remotely (maybe I should quit while I’m ahead. Thanks again for your help.

Hi @JACK_WILLIAMS,

Can you please double check to make sure that the DAC is not selected as the Windows output when this issue occurs? By this I mean to make sure that it is not the top item listed when you click on the “volume” icon in the taskbar’s bottom right-hand corner.

I’m glad that it’s functioning with the workaround, but this behavior is strange, you shouldn’t have to disable all other outputs to get your one zone to work.

Hi noris, yes, the DAC is selected as the Windows output device and is the default in the Sound Control Panel. Not sure what you’re getting at? Tx

Hi @JACK_WILLIAMS,

I am saying if you do not have Windows select this device as the default, does the same behavior still occur? Sometimes when you set Windows devices as defaults, it automatically engages “Exclusive Mode” for the DAC, which is essentially Windows telling the DAC - “I want complete control of this device and do not let any other applications interact with it while Windows is using it”. If you have this configured so that the DAC is not running on exclusive mode, does the same behavior above still apply?

Yes, the DAC works fine when it is not selected as the Windows default, so it seems that Windows is not taking control. Everything is running well now, whether Tidal audio is set for exclusive or not, according to correct info from the Signal Path. All other audio devices are not exactly disabled, they are labeled “enable.” Sorry if I misled you in any way. Thanks for your suggestions!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.