File Copy to Nucleus

Core Machine (Operating system/System info/Roon build number)

Nucleus Rev B
Ser. Serial #54B2030EA4BE
Roon OS Build 183
Roon Server Software build 511
Roon Labs software build 12
Installed 2TB SSD for internal storage

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear ORBI router + three (3) satellites (mesh system)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

I recently purchased and installed a ROON NUCLEUS Rev B. The install was simple, and worked without a hitch. My issues is that I want my streaming library (TIDAL, QUOBUZ) physically stored on the internal SSD. I live in the mountains of Colorado, and sometimes lose internet connectivity for a variety or reasons. No Internet = No Streaming and No Access to Library.

I am unable to find documentation as to how to physically have my library stored on the internal SSD.

Related, when I try and IMPORT music from a USB connected directly to the Nucleus by “dragging and dropping” into the Internal Storage Folder (SSD) the system crashes. I am running Roon software on a Microsoft Surface with 64 bit Windows 10. (Roon Remotes include a Galaxy Tab and a OnePlus Android phone.)

The (simple) overall question is “how do I get all my music to reside locally so internet outages do not result in … silence?”

Unless I am misunderstanding; local storage of Tidal and Qobuz content does not happen with Roon. Only Tidal and Qobuz’ actual applications are licensed to store and play music locally.

Edit, sorry missed that you had a 2nd installed data drive in the Nucleus.

If you have a 2TB SSD then you’ve obviously added an additional internal SSD. Correct? Did you format it from the nucleus web menu? There is a format button for the internal SSD and if properly formatted you’ll see the size and unused availability of it. If you haven’t formatted it from this UX do it. Reference this if you need to:

Assuming you’ve done all this, I’d connect the external USB with your music to a separate mac or windows computer and do the copying from the now local directory (your USB) to the remote internal SSD on your nucleus. You can use drag and drop but you might consider a tool like chronosync that will pick up where it left off if it fails for some reason which is easier than recovering from a drag and drop failure.

Thank you, Rugby. I wasn’t aware that we could not store Tidal and Qobuz tracks locally. I will check into that.

Hi Craig,

I did indeed format the internal SSD using the nucleus web menu. The nucleus “sees” the usb drive that is plugged directly into the unit, and is “watching” it. But trying to copy music fails after 1 or 2 tracks, the program crashes, ie, closes. The drag and drop will sometimes work if I select single tracks, but fails on copying multiple tracks or multiple folders (albums).



I would try as Craig suggested, plug the usb into another PC and then from that PC use it’s file manager to copy from it to the Nucleus storage.

OK, I moved the USB drive from the nucleus to my laptop. Drag and drop (sort of) worked in that the tracks/folders copied with only 3 crashes. Thank you.

This is why I recommend using a tool like chronosync to sync large amounts of data to a nucleus ssd. It’s much more robust than drag and drop…

I’ll track it down…

Not sure if your laptop is mac or windows. Chronosync is for mac. There are plenty of others for windows but I no longer use windows so don’t know what is best for that. I do all my metadata editing on my mac and keep the master copy of my music there on an attached disk drive. I use Chronosync to sync any changes to my nucleus every night. I also use it to sync another backup of my music from my Mac to a NAS. It’s a very handy tool, full featured and robust.

Windows, and thanks. I’ll look for a file-transfer utility. Should be easy to find. Appreciate the info.

Hi guys,

Any tips on a Chronsync alternative for Windows 10? I’m about to copy my library from a NAS to an SSD on my Nucleus, and also not keen to do it drag-and-drop.


I’m using TeraCopy to transfer, which seems to work fine.

I haven’t gotten back to this yet, but based on Simon_Calder’s last post, will try TeraCopy.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.