Filesystem watcher doesn't seem to pick up changes for smb shares

Core Machine (Operating system/System info/Roon build number)

ROCK OS 1.0 build 186 stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet, and on a couple vlans, but that isn’t applicable. The core sees the shares just fine.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
USB to a Schiit Gungnir

Description Of Issue

Unless I do a force rescan, new tracks don’t show up until the timer kicks off (every 4 hours). I haven’t seen anything I can tweak outside the Roon configuration page as ROCK is embedded. Any reason why the filesystem watcher isn’t catching changes on the samba shares?


AFAIK exactly that is what the timer is for (check for new or changed files every X hours). You should be able to change the timer to something that suites your needs better – or just get used to “Force Rescan” every time you added or changed content if you’re impatient.

Maybe setting “max protocol = SMB3” in SAMBA turns on “Real Time Watching” (a restart of the Roon Server software may be needed after the change to make Roon aware of it) but is prone to be unreliable or not working at all. Try it out and see if it works for you.

1 Like

Thanks, I already had that directive in the samba configuration. I suppose I’ll drop the timer to the minimum and force rescan when I must :smiley:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.