First Few Seconds of Audio Skipped via Chord M Scaler (but not DAVE alone)

Core Machine

NUC7i5BNH Running Roon ROCK 1.8 (build 795) 64 bit

Network Details

WiFi via ASUS router being used as access point

Audio Devices

NUC → Chord M Scaler → Chord DAVE → tube amp → Focal Utopia

Library Size

20 local albums, and streaming via Qobuz and Tidal

Description of Issue

When selecting a completely new track via streaming, the first fraction of a second gets cut off. This is particularly noticeable for tracks that don’t pre-roll silence, as they have the first audible beat or so cut off. This used to happen to me when I was using a Chord Hugo 2, but seemed to go away when I increased the Resync Delay. I eventually moved up to a Chord DAVE, and never had an issue. However, since adding an M Scaler, the issue is back, and consistent, no matter how high (or low) I set the resync delay. Notably, this does not happen for locally stored music. Additionally, even when streaming, no music is skipped when I allow tracks to flow one to the next, making me think the start of the next track gets cached, thus removing the issue. If I start a track, allow it to run a few seconds, and scroll back to the start of it, the first beat comes back.

I’d be very grateful for any assistance or ideas for how to remedy the issue.

If you have the mscaler on auto input selection you could try selecting the input you use eg USB.

It can also be that the bnc cables between msc and dave are a bit borderline in quality eg if you use the cables included with the msc.

Edit: just read that it only happens with streaming … strange then I have no idea. Sorry!

Hello @Andris_Zvargulis,

Thank you very much for getting in touch about this and sorry about the trouble!

I was wondering, if you play the same tracks outside of Roon (so, directly from Qobuz and TIDAL) does this still happen?

As a first step, could you please try making use of resync delay? We explain it here:

Thanks in advance :pray:

Hello @Andris_Zvargulis,

It doesn’t make sense to me that this behavior affects streaming playback but not local playback. I’m not ruling out the possibility, but having some knowledge about how Roon caches and plays audio they should behave identically given the same sample rate and bit-depth.

Is it possible that the streaming content you’ve been testing with is a different sample rate verses most of your local content?

Using the M-Scaler and DAVE, I often see this behavior when switching between formats.

I’d also try using BNC inputs 3+4 on the DAVE, they are better behaved in my experience.


@beka - Thanks so much for the suggestion! I had played with the resync delay before, but having read the article you sent, I realize now that more isn’t always better. I kept trying to increase it, and it wasn’t helping at all. However, ~500ms seems to be the sweet spot (I had even tried 10,000 ms, but was having the issue). I also set the buffer size to 50 ms. With those settings, I haven’t gotten a blip yet!

@john - Thanks for reaching out! Yeah, I also thought it was super strange that only streaming had the issue. However, it seems that I just had to fiddle with the resync delay and buffer size, and not assume higher values should have helped more. So far, it’s working on BNC 1,2, but if I run into issues in the future, I’ll try BNC 3,4. My local content and streaming content both run the gamut from 16/44.1 all the way to 24/352.

Thank you both for the outreach and help. Soooo much less frustrating not having the song starts cut off :slight_smile:


@beka , @john

Darn, you know what - I spoke too soon. I went through a nice long string of not having any issues, and then it started happening again, and pretty consistently. I tried to find some sort of pattern to be helpful, and I do notice that it happens more often the longer the initial loading sequence (track bar animation going back and forth) is. Screenshot below for clarity:

I’ll keep trying to play with the various resync delay and buffer sizes, but this gives a little more credence as to why it’s happening during only streaming playback. When the loading sequence is snappy, I don’t experience the dropout. When the loading sequence takes several seconds, I get the dropout. I’m currently streaming via WiFi. I might try to hard-wire my NUC via ethernet and see if that solves it. Even if my WiFi isn’t perfect, I’m not sure why the start of the song should drop given the buffer, but maybe one of you has more insight into that.

Strange that no one seems to have noticed yet, but I very strongly recommend testing a wired connection to the core, as using WiFi in that place has been proven to be problematic time and again.
Give it a shot and report back, please!

I’m going to try it, but at the same time, I don’t think it should matter. I’d be more willing to blame the WiFi, but I didn’t have this issue with Hugo 2 or DAVE w/o M-Scaler - all in the same exact location and setup. I just don’t have a practical way to keep the NUC hard wired right now, as I’d have to run a cable through two rooms, across the floor, and my wifi speeds are perfectly fine. I just measured 80 mbps down. It’s not like the songs intermittently skip - it’s just the first fraction of a second. As such, it’s clearly something to do with buffering and the start of playback.

I hear you, but it’s just a test to rule out that faint possibility.

@beka , @john

Heyo. Just thought I’d provide an update. I tested using BNC 3+4 on Dave (instead of 1+2), and there wasn’t any difference I could tell; I still got the track beginning dropouts. I also tested with a hard-wired ethernet connection (confirmed by disconnecting the wireless setting entirely), and while the starting dropouts were more infrequent, I could still get them to happen on occasion.

Just as before, never ever with local files. Only with streaming files.

It’s not the end of the world, but just a constant, minor annoyance. Anything else I should try?

– Andris

Hey @Andris_Zvargulis,

Thanks for keeping us in the loop and thank you for the effort you put in to try so many solutions :pray:

For next possible steps, our technical team would be best able to help.

Please, stay tuned. They’re looped in on this thread :pray:

@beka - Sounds good! Thanks for checking back in, and I’ll await word from the technical team :slight_smile:

1 Like

I’m so sorry this was missed, @Andris_Zvargulis.

Are you still seeing this problem occur? If so, here’s what I’m hoping you can do:

  • Reproduce this issue a few times and make a note of the track names and time that you press play
  • Respond here with that info and use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service).


This topic was automatically closed after 21 hours. New replies are no longer allowed.