Force conversion of DSD to PCM


(Alan Murray) #1

Hi there, I’m having a problem configuring Roon to convert DSD to PCM on playback. My current DAC does not support DSD but Roon is insisting on sending it DSD data. This is likely because my streamer does support DSD. I can’t seem to find a way to force this conversion to take place.

Here is my config, showing 2 playback chains terminating at the same (non-DSD) DAC. One is properly converting to PCM and plays back well. The other is sending DSD and of course plays only hiss as expected.

Roon version 1.5 ( build 363)
Core: ROCK Roon version 1.5 (build 363)

Playback Chain 1: (not working)
SimAudio Moon MiND (ethernet in, Coax out)
Berkely Audio Alpha DAC

The MinD supports DSD, the Alpha DAC does not

Playback Chain 2: (working)
Sonore Microrendu (ethernet in, USB out)
Berkeley Alpha USB (usb in, AES out)
Berkely Alpha DAC

Here are screenshots of the Device Setup for each streamer:

Simaudio MiND (not working)

Sonore Microrendu (working)

Any help to put me on the path to resolution would be greatly appreciated.

Alan


(Daniel Beyer) #2

It looks like since the MIND does accept DSD then Roon does not give you the option to set DSD playback (Convert to PCM/ Use DOP / dcs Playback) at the device level. Unless I missed something from your screen shots.

You can use DSP to convert the DSD to PCM. Go to DSP settings. Sample Rate Conversion (remember to enable the setting). First option, select the drop down and choose Custom. Scroll down and you should see DSD playback, use the drop down and select the PCM resolution to convert to. Do this for each DSD line.


(Alan Murray) #3

Thanks @Rugby,

Let me try that and see if it resolves the issue. It looks like with that option I will always have DSP enabled, not sure I have an opinion either way on that, I’ll have to listen.

Thanks for the suggestion.

Alan


#4

This is interesting. I have a MiND2 streamer feeding a bel canto dac via AES/EBU. I don’t presently have any dsd files, but I may perceivably run into the same issue if I were to try dsd, as it’s not supported by my dac.


(Daniel Beyer) #5

That is where the Roon conversion settings are located. You will have the same conversion no matter where it takes place or what software/hardware does the conversion. It is not really DSP as you are thinking of it. Better to have Roon do it.


(Jason P) #6

if you have the mind 2 steamer it should be Roon certified.Should be able to do dsd 256 over usb or ethernet.


#7

Well, yes but since my dac further down the line doesn’t support dsd I suppose I’ll have to set up roon to do initial dsd->pcm conversion in the dsp settings, same as @Alan_Murray


(Alan Murray) #9

That did the trick. Thanks for point me in the right direction. I’d looked in DSP settings before but was looking for a global option, I hadn’t gone down the custom route, piece of cake. Thanks again.


(Alan Murray) #10

@oafrenning this worked out well for me. I had considered converting the files to FLAC. This is better way to go. I still have the option in the future of a DSD capable DAC and Roon’s conversion as good as it is may get better yet!


#11

Thanks for sharing! I know the local dealership is ecstatic about the t+a dac8 dsd - saving up all I can :smile:


(system) #12

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.