Freeze with very short gapless tracks

Hello,
when playing several very short gapless tracks (4s), playback is blocked from the first track. I must then restart the KEF LS50W to be able to use roon again.
You can test with the following album:
AYREON - The Human Equation (Disc 2) and start playing the disc from the beginning.

Just played Disc 2 all the way through to my Pi with a HifiBerry Digi+ Pro HAT. No issues.

Tim

1 Like

Hi @Le_Fur_Arnaud ---- Thank you for the report and sharing this observation with us. The feedback is greatly appreciated!

Like @anon97951896 did (thanks Tim!) I also gave Disc 2 of the mentioned album a spin with the setup I have at my desk and had no issues during playback. In light of this may I kindly ask you for the following:

  • Please expand on the description of your setup using this link as a guide.

  • Please provide a screenshot of your signal path leaving Roon when the issue occurs.

  • Is the device hosting your core making use of Wifi? How about the LS50Ws?

  • Can you confirm if other endpoints in your setup display the same behavior? Furthermore, is the mentioned album in your post the only one having the issue is ALL content in your library (local and TIDAL) performing this way?

-Eric

Hi,

My setup @support :

  • Latest room version
  • OSX 10.11.6
  • iMac mi-2007 2 GHz Intel Core 2 Duo, Go 667 MHz DDR2 SDRAM
  • NAS Seagate Personal Cloud 1-Bay
  • Library +20000 tracks (no Tidal only local files)
  • Latest KEF LS50W firmware

Nas, iMac, Kef are all connected via WIFI no USB cable.
Roon control from iPad.
It only happens with this album so far (all other gapless albums play nicely)
If output to iPad it works, so i think the problem is with KEF’s firmware.

Arnaud.

Hi @Le_Fur_Arnaud ----- Thank you for the follow up and providing the requested feedback. very appreciated! A few things moving forward…

I tested the same album on the KEF LS50Ws we have in the QA lab (core on Wifi and LS50Ws on Wifi) and had no issues again. I did notice from your latest screenshot that I am not seeing the same tracks on the TIDAL version of the album (see below):

-Eric

Hi @support,

I don’t use Tidal. I use my CD ripped in ALAC.
The original CD has intro to “Day Twelve” artificially subdivided in 11 very small parts (4 to 9 seconds)
I know it’s stupid but it is.

Tested with Libratone Zipp via AirPlay : works fine.
The problem is definitely with Kef’s firmware.

Arnaud.

Hi @support,

Are you still investigating ?
Can you reproduce the problem ?

Arnaud.

Hi @Le_Fur_Arnaud ---- Thank you for getting in touch.

As mentioned above I tested this album (via TIDAL) with the KEF LS50Ws we have in the QA lab using a similar setup to yours and was unable to reproduce the error mentioned in your report. I have been doing some research on this album and every search results comes back with the same track listing, and furthermore “Day Twelve: Trauma” is always listed as having a 9:54 runtime.

You mentioned in your follow up that this track was “artificially subdivided”, what exactly is meant by that? Is it possible that an issue occurred while you were ripping this CD? Since having this issue have you tried re-ripping the album?

-Eric

Hi @support,

Here is the screenshot for CD2 before iTunes import.

The KEF’s are not playing gapless when using upnp that’s why i’m trying roon which is working perfectly gapless except for this particular album.

The problem is certainly due to the multi short gapless tracks not being well managed in KEF’s roon implementation.

Arnaud.

Thanks for the follow up @Le_Fur_Arnaud, appreciated!

I am going to be opening an investigation to see if we can run down the cause of this behavior. Your patience and understanding is appreciated during this process.

-Eric

Hi @Le_Fur_Arnaud ---- May I kindly ask you to please make a copy of the tracks that are displaying this behavior and send them over to us via a [shared dropbox link](or another upload service of your choosing) in a PM addressed to me for testing.

Thanks!
-Eric

Hi @Le_Fur_Arnaud ---- Touching base to let you know that I have seen your PM and have downloaded the media sample. Thanks!

-Eric