Frustrating KEF app issue

I bought a pair of these second hand just over 2 years ago as a degree completion present. I set them up for him and they have been fine and he mainly uses them in PC mode as he records and produces in his (expanding) spare time.

Anyway he was complaining of a intermittent buzz so I decided the first thing is to get in the latest firmware. It took a few goes, not working on his Mac but my surface pro did the update with one slave speaker error.

Now the app connection floated in and out so I did a factory reset. Now the control app connects okay but I cannot seem to get the sound settings to work. Once I go to this screen it try’s to connect with spinning circle and then says cannot connect. The streamer app works okay and all other aspects of the control app.

Any ideas on this issue? Is there an incompatibility with the new app and an earlier speaker and if so how do I change the sound settings in the expert mode?

Thanks,

.sjb

Hi John,

I have an early LS50W as well, but can’t say I’ve had any issues with the current app on them.

Best thing I can suggest is to use the app, do exactly what you’ve done to get into the speaker sound settings, and then hit the ‘three dots’ in the top right of the home screen, and select ‘Send Logs and Feedback’ at the bottom. That will open up your email.

After it says ‘Please give a short description of the issue you are encountering’ type up what you’re seeing, and include info like the router make/model. When you email it, it will also email the logs of that session as an attachment. That will go to customer service.

I’m afraid that’s as much help as I can be.

Best regards,

Ben

1 Like

Thanks @Ben_Hagens, I appreciate your response.

My sons iPhone has the old app n it and this worked to reset it up.

Through trial and error it seems that if I create a profile in the new app, that I can access and change the settings.

As I have you here my son experiences an intermittent buzzing in the right (slave in our case) speaker. The same speaker failed with the firmware update and I removed and reinstated the Ethernet cable between them. The update then worked. He says the buzzing is improved but not eradicated (the main reason for me getting involved in updating the firmware).

Any ideas?

.sjb

Hi John,

Really sorry about the delay in reply, I hadn’t caught the notification email.

Is the buzz on all sources? Also, try with another ethernet cable if you have one handy (a Cat6 would do).

Hi Ben,

this issue has got worse, I had a listen this evening after asking him to try the following:

  • invert speaker L -> R, same speaker buzzing
  • use another ethernet cable - same issue
  • disconnect all inputs and use as a Spotify control endpoint, same issue.

I had a listen and it’s what I’d call distortion, the unit is about 3 years old. I’m not the first owner. I’m in Dublin in Ireland. What’s my best options?

Thanks,

John

.sjb

Hi John,

I think best course of action would be to contact the U.K. Service Team. They’ll be much more help than I.

There is a service centre number at the bottom, but I honestly don’t know if that is manned at the moment due to the Covid-19 situation.

1 Like

Just to close this loop.

Eventually at the end of the lockdown I contacted the original suppliers in Ireland, HiFi Hut, they returned the KEFs to the island of Ireland distributor in Belfast and thence on to Kent (I presume).

Collected them last week, the son says they are fixed and I was not charged so kudos to KEF, their Irish distributors and HiFi Hut.

No accompanying literature or input to let me know what the issue was but I’m a happy camper and much more predisposed to KEF as a company.

Kent Engineering and Foundry, I’m a happy customer.

.sjb

Happy to hear it’s sorted, John :+1:

1 Like