Getting ARC to work on AT&T fiber (Arris BGW210-700)

Roon Core Machine

ROCK on Intel NUC10i7FNHC (i7 processor), 8GB DDR4, >128GB SATA internal (or greater size—don’t recall)

Networking Gear & Setup Details

Router: AT&T by Arris BGW210-700*

On Core side: Netgear Unmanaged Switch model GS305v3 (temporarily removed and observed not to make a difference)

Connected Audio Devices

Core library on External SSD connected by USB
Okto Research DAC8 Stereo

Number of Tracks in Library

Under 5000

Description of Issue

Roon ARC unable to connect to core in Settings.

*Same fiber connected router as here, but tried everything listed without success.

I’ve got the router set to fixed allocation for the DHCP, and also copied the DHCP core settings to Static IP tab.

IP passthrough on router is set for core’s MAC address.

The router’s NAT/gaming Firewall is set up for the core with TCP and the port range is 55000-55000 (only). Making this too wide caused conflicts.

Testing the port through Roon still yields this:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

I have re-booted everything, as in the link above was found to fix for the other user with same router.

What should I try next?

The port forwarding diagnostics you’ve provided suggest that UPnP is not properly configured on your router or not working correctly.

Please try the following steps in order:

  • Reboot your Roon Core and networking gear (router, modem, switches, etc.)
  • Try to enable UPnP/NATPMP in the web administration interface for the router
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Try to update your router firmware
  • Check if your modem is in Bridge mode and if not, try to place into Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?


Thank you for the detailed reply, Martin. The support site for the router makes clear that it does not support UPnP/NATPMP, at least without adding another 3rd party device, which would not be worth doing for me. It also is stated not to support Bridge mode. AT&T recommends IP Passthrough mode, which looks to me to be correctly configured.

My router’s firmware is kept up to date automatically and I’ve verified again its NAT/Gaming Port matches that in Roon Settings.

Unless there’s something more obvious I’m missing, and in spite of the other user with the same modem reporting eventual success (linked above), I believe I’m going to need to punt the ARC feature. My need and desire to use Roon outside the home is trivial anyway. I can still rely on Qobuz including its Offline feature, so this is not a killer Roon feature for me. (Come to think, I almost never listen to my core library anyway. It’s radio streaming or Qobuz.) So maybe wrong audience here.

Thanks again for your help and time.

To be clear, have you setup port forwarding? Opening the port is insufficient; it needs redirection to your core.

Yes, see attached image showing my core’s MAC address. Also I have saved and reset devices since configuring this.

Thanks again.

You’re using the wrong screen; this is for use when you have a router connected to the Arris. Return the IP Passthrough page to its original settings.

Use port forwarding, which is found under the NAT/Gaming tab:

  • Service: RoonARC
  • Ports: 55000 (or whatever is shown under Roon > Settings > Roon ARC)
  • Device: The IPV4 address of your core

That was the first thing I tried:

ROCK is the name of the IPV4 address. ¯_(ツ)_/¯

Clarification from prior screen tab before “Service Details”…

Service name is anything; device is the name of the IPV4

Hi Charles
Not sure what is going on with your setup but I have exactly the same AT&T router and enabled pass through, set the mac address and port range (55000 to 56000) and it was instantly ready for Arc, not even a reboot required.
This I did literally 10 minutes ago…lol, I am a bit like yourself as could not be bothered with Arc but upon reading this I thought I would try.
Its syncing right now.

Try setting port range to 55000_56000.
I have found it seems to want to hit 55002 doing its own setup in testing.

Thanks, Ace. I tried that and rebooted the router, but still no luck. Resetting the listening port on Roon ARC settings did change the port to 55002, but still no go.

That you have the same router gives me a little more optimism that I can eventually get it going.

The only other slight difference I see in your screenshot to mine is the protocol.
Yours says TCP, mine says TCP/ udp.
Not sure if that’s relevant?

Providing your Mac address is entered correctly ( I got mine via the drop-down of units on the network) I see nothing fundamental different.

“No Application Hosting entries have been defined”

This is the problem. Did you click “Add”?

Well, well. You’re right! That’s interesting, because of how confusing those screens are. (Of course these kinds of UIs are notorious for that, and I thought I was keeping that into account.) I thought (and thought I earlier proved) “Add” was found only to add additional new entries.

If you don’t add here, it not only saves the entry (without defining it, I see now :roll_eyes:), if you select “Custom Services” under “Manage (same),” it then shows it as a service that can be edited or deleted! That’s where you have to set it up, which it confirms as a saved change! Then it gets more confusing, because if you try to add it from that screen, it gives the error below.

(So note to others, don’t get fooled thinking this service is defined and don’t add it here; it will try to add blanks in the empty fields, which may lead you to conclude the above “service list” is already defined. Here, it does try to add new ones only to the above list, but they’re not necessarily defined. Defining only happens from previous screen.) I think that’s where I got tripped up, though of course also thought I’d tried every combination. :grimacing:

I did not. Mea culpa.

And now ARC is working. Thanks, all!

1 Like

Also, 55000 to 55000 port range is actually okay, at least so far.

Just saw this. TCP alone seems to be okay too.

Thank you!

Well spotted!
Nice when it’s something silly but I do agree that the AT&T menus are terrible especially in this area and it’s easily done.

Glad it is now working
I was going to add something but as you are up and running I would leave well alone now…lol
I found that using passthrough I lost all of my Google CCA units.
I changed to default server entering the ip of the Core as it used to be prior to setting as passthrough, rebooted everything and this gave me back all my CCA units and still have Roon Arc.
Might be good information for any other Arris BGW210 users I think.

1 Like

I turned off Passthrough. All good!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.