Getting horrible clicking when attempting to play high res audio (OS X)

Wow. Not sure what happened, as a lot of stuff changed in the last 3 weeks or so, but it’s made listening to high res audio impossible, whereas prior it was fine:

First, my setup:

Mac Mini running Roon Server 1.2 build 161
macOS Sierra 10.12
Gigabit Ethernet

Trying to play to:

Mac Pro running Roon version 1.2 build 161
OS X 10.10.5
B&W MM1 USB speakers


  1. I go into my library, and attempt to play a 24/192 FLAC file (any in my collection, really), and the audio starts making a very loud clicking noise while playing. The noise is so loud, it’s potentially damaging to my speakers. the clicking starts often before the audio plays (but after I hit play).
  2. The clicking is pretty rapid as well. Probably 4-6Hz. It’s not a click between songs, but like a machine gun of constant clicking during playback.
  3. I hit stop, and the audio stops, but the clicking continues for several seconds before it stops.
  4. Sometimes it plays, then tells me to select an audio zone… as if my end-point (mac pro, aka my desktop computer) went offline (which it obviously didn’t).
  5. This makes it impossible to listen to a large portion of my audio collection via Roon.

Other Insights

  1. This doesn’t seem to happen with 16/44.1 audio as much, but audio quality is still compromised (pops, micro dropouts)
  2. I recently upgraded from OSX 10.11.x on the Mac Mini after macOS Sierra SMB problems were fixed in Roon
  3. Roon got 2 updates recently, but I don’t believe I listened to anything between the two updates, so I can’t isolate one over another to be the problem (if either are)
  4. Other apps can play these files just fine, and at full-resolution (Vox) over the network.
  5. I manually went into the Audio MIDI Setup utility and made sure it was set to 24/192 (although that shouldn’t matter, as RAAT should be handling all that, right?). (I Manually changed it to 16/48, then changed it back to 24/192, just to potentially overwrite a corrupt setting). This had no effect.

Any ideas? I realise there are a lot of variables here, but 3 weeks ago, it all worked perfectly, and now it’s pretty busted. Is there a log I can provide someone with?


I reverted my Sierra install disk to 10.11.x (always make a backup, folks!) which also had the old Roon Server on it. My Mac Pro still had the latest build of Roon on it though, and playback still had the horrible clicking problem.

However, playing to my pre/pro Anthem AVM 60 from the (reverted) Mac mini plays without clicking issues (I get the violet dot). This setup is: Mini (reverted) Roon Server, controlled by current version Roon on the Mac Pro, output to my Anthem AVM60/ B&W 803Ds. Switching to output the same song on the B&W MM-1 still results in horrible clicking.

So, in short:

Old Roon Server output to Anthem == Good
Old and new Roon Server output to Mac Pro’s USB B&W MM-1s == Bad

I even tried unplugging the USB cable from the MM-1s to see if that’d fix it, but it didn’t.

Second Update

This video shows/has audio of the issue. Note that the automatic gain control kicked in, and the audio in the video is far softer than in reality.

if the video isn’t playing, go here:

Thanks in advance.

Hi @CM_Harrington ---- My sincere apologies for the slow response and thank you for the very detailed report :+1:

Due to the fact that you had no previous issues with this setup, is there anything you can think of that has been adjusted to your setup? New gear? OS update(s)? Driver/Firmware updates? New applications running?

Furthermore, have you tried limiting the output to the B&W USB speakers via the settings found in the “audio” tab for that zone (Max sample rate = 48khz & Max Bits Per Sample = 16)?


@Eric The things adjusted in the setup are what was described in the before and after portions in my writeup (part of the problem is a bunch of stuff changed kinda all at once, and I can’t fully isolate the variables).

As per your suggestion, I manually limited the MM1s to 16/48, and while the very loud clicking stopped, the audio is horribly distorted (which again, plays fine in other apps).

While I haven’t been able to isolate all the variables, I’m thinking that my testing is leading to the combination of OS X 10.10.5 (now 2 major versions out of date, yet still most stable, sadly), and Roon 1.2 b161.

Is there somewhere I can DL the prior release for testing? (one of the problems with automatic updates is if something goes wrong, it’s much harder to revert as you don’t have a separate installer).

I only have about 4500 songs in my collection, so if I need to nuke a database and rebuild or something, I don’t have a problem doing that.

Oh, one thing to make a bit more clear… I mentioned in the OP reverting the Mac mini to 10.11.x to test it out, and once that test was over, I went back to the 10.12 (Sierra) and latest 161 build of Roon Server.


Hi @CM_Harrington — Thank you for the follow up and taking the time to answer my questions / perform the proposed test. I am sorry to hear conditions have remained the same.

Moving forward, I touched base with one of my developers today to discuss this issue and would like to gather some more information from you. Please see below. Thanks!

  1. Can you please provide screenshots of your zone settings in roon.

  2. Has the firmware on the B&W MM-1s been updated recently? Could there have been an automatic update with these speakers?

  3. I apologies if I missed this in your report, but can you confirm if this “machine gun” sound is present when using the “new roon server setup” connected to Anthem DAC?

  4. As a test, could you please plug a set of earphones into your core machine and playback from roon out of the internal sound card and confirm if the issue is still present.


@Eric Please see my replies inline below:

These are the screenshots. of both tabs. Note: nothing in “General” has changed before or after this problem.

No, it has not. There are no automatic driver updates for these speakers. I’m running v3 of the firmware which was put out several years ago (payload dated 2013, installer dated 3/2015).

It is not present in the Anthem with any version of Roon or OS (apologies if that was confusing). The problem is isolated to the Roon app on the Mac Pro w/MM1 (as controller/output) connected to the Mac Mini’s Roon Server (database aka core).

My “Core” machine is running Roon Server (the mini), so it can’t really be an output. I did however, run a pair of headphones directly via the Mac Pro’s front headphone jack, and it does not exhibit the ‘machine gun’ clicks, nor does it seem to heavily distort the audio when downsampling from a high res (24/96 in this case) audio file.

Note that I had to set up a new output in Roon. The settings were default (Core Audio mixer, both max sample/bit depth disabled, in NON exclusive mode).

So it seems the problem is specifically isolated to the MM1.

Any other suggestions? I’d still like to try an older build (like the one that was available pre-Sierra launch) to see if it’s a particular combination of my old OS on the Mac Pro and the newest build of Roon.


Just jumping in here, but have you tried Exclusive Mode for the MM-1?

Cheers, Greg

@Greg Thank you for jumping in! More eyes more bettererer!

So… guess what? I clicked on Exclusive Mode, and it did not have the clicking problem, nor the distorted audio problem!

However, Exclusive Mode isn’t practical for my setup (Those speakers need to be used for other system/app sounds during playback)


I turned off Exclusive Mode and tried playback (with the max sample rate/word length matched to the MM1’s max output of 16/48)… no machine gun clicks and no distorted audio!

So next, I tried unsetting the max sample rate/word length (ie, back to disabled), and lo, audio is fine as well!

So, beers/beverages for everyone!

As a scientist though, I want to understand why this could have happened. Some corrupt bit flipped somewhere in the prefs? If you’d like, I’ll be happy to continue to conduct tests to try and reproduce the condition.


That’s great news.

Regarding the sounds from the system coming through the speakers, I’m wondering if there’s a way to have music go through USB to the MM-1’s and system sounds go through the Internal Speakers. Would that even work for you?

Go into System Preferences and select Sound. Under the Output tab, if you select Internal Speakers for sound output, do you get system sounds out of the internal speakers and music from the MM-1’s (set to exclusive)?

I don’t have a USB DAC connected to my computer, so I can’t try myself.

Cheers, Greg

I can’t do this at the moment, but I have done ‘fancy routing’ in the past with other audio apps (like Logic, or Audition) where the app’s audio exclusively goes through one output while the rest goes out another.

Unfortunately, that’s not something that will work for me for this case. My MM1s are not my ‘critical listening’ output (That would be the B&W 803Ds), as they need to do ‘omni’ duty for my workstation (mac pro). Being able to get Roon to output to them is important, as it means I don’t have to fire up the ‘big’ system, but it comes at the expense of also needing to hear system stuff, and other app noises (like, say, otter videos on YouTube :wink: ).

Again, thanks much!


I, too, developed this problem with my Mac Mini server tonight. No updates have recently been installed to my Mac Mini as I have auto updates disabled. I searched the support area and found this post. After switching to exclusive mode the problem is solved for me as well. Since my Mac Mini serves no other purpose but to serve music to my DAC I can leave it there and be happy with the sound.

While I’m pleased this terrifying problem is resolved, I, too, would like to understand the cause.

Thanks to all!


1 Like

@CM_Harrington & @Peter_Blandino ---- Thank you both for feedback. I briefly touched base with one of my developers today and brought up this issue that both of you have/are experiencing and was offered the following insight:

" In short, changing audio settings resets our relationship with the sound card. If exclusive mode is just flipped off->on->off, then that’s probably why it had an effect.

"Generally, turning exclusive mode off is much less demanding of hardware/drivers being good, because it causes our audio to go into a software mixer with everything else running on the system, so it’s business-as-usual from the hardware’s standpoint.

Peter, what type of DAC are you working with?


Thanks for the follow up information, Eric. My DAC is a Line Magnetic 502.

So I hadn’t used Roon in a few days, and when I went to play some music, I got the same old clicking issue. Toggling Exclusive mode indeed once again fixed it.

As this never happened with the prior versions of the software, I’m wondering if there’s a bug introduced with the new version? (again, I don’t have an earlier version to test against)