Getting HQPlayer to Output to DAC

Okay, my PS Audio Perfect Wave II DAC works fine with Roon. I installed HQPlayer. Under Roon Setup_Audio, both are shown under Roon Ready. When I choose PS Audio DAC and then start a recording playing, it works fine. If I then select HQPlayer while the recording is playing, Setup shows HQPlayer is selected, but the music moving vertical bars to the left of the HQPlayer zone box are not active. Those in the PS Audio box are still active and I still get the music. If I start out selecting HQPlayer, its vertical bars move, but there is no music and the musical selection is not showing on the DAC display.
Trying to make this simple: When I open the HQPlayer Settings screen, I see an Output Device Settings section. Under Backend, it is set to WASAPI. Under Device it shows Device Endpoint. When I select that, PS Audio does not show, just Headphones and Speakers. Yet PS Audio is set as a Zone (correct term?) in the Roon Setup_Audio. Is this my problem? Is it fixable? I will repost my HQPlayer setup screens.

So looking forward to getting HQPlayer working!

Yes in Roon you need to disable your DAC in Audio setup

The only enabled zone in Roon should be HQPlayer

HQ is the only enabled zone in Roon now. All the other zones say ENABLE next to them. When I select a track, HQPlayer is playing, it shows the moving vertical bars at the left. But still the DAC is not receiving the data as evidenced by the display screen not showing the selected album/track, and not producing any sound.
Thanks so much for helping me!

While WASAPI should work can you try ASIO driver option?

Also change your “Vol Max” to -3dB

I made those 2 changes. Progress! When I selected and played a track on the remote device, it responded
At least it is responding with normal messages, without a good final result.

How did you setup HQPlayer in Roon?

Is Roon Core and HQPlayer running on same PC?

Roon and HQPlayer are definitely on the same PC. I turned on HQPlayer, then went to Setup in Roon, clicked on HQPlayer, then as instructed went to Settings_Audio and didn’t actually change anything. HQPlayer appears now in Roon as the only active zone.

After disabling all the other Roon audio devices, you might need to power cycle everything.

Reboot DAC and Windows and try again?

You used “localsource” when setting up HQPlayer in Roon?

Also try and drag a FLAC file into the main HQPlayer window and confirm if that track plays (not using Roon this test)

Local source doesn’t work for me. I have to use the IP number of the computer.

Remember after Roon hands off the audio to HQPlayer. HQPLAYER is then responsible for sending the audio to the Endpoint, not Roon.

Good point, something to try

That is the point of my suggestion above, to check HQPlayer is actually working properly with DAC:

Then, just load HQPlayer and try and play music from it to the DAC. When you can, then, add Roon in.

1 Like

Yes that’s exactly what I wrote :grinning:

1 Like

Still working on it, have to quit for the moment, probably until tomorrow morning. Thanks again for your help!

1 Like

Attempting to play a file using HQ Desktop and HQ Client, Roon not turned on. Set Client alternately to localhost and IP4 address. Tried to drag both folder containing flac files and individual flac files to HQD library section or all over the place. As I drag, the ghost image of the album cover says +copy, but nothing lands.
Will continue trying to get Roon + HQD to work.

For this quick test, no need to use HQP Client.

Just drag one FLAC file into this window of HQP Desktop. And press play.

Did that. Dragged flac file into that area, it showed +copy, I let go, nothing went there. Pressed PLAY and, of course, nothing happened.

2 adds to last reply:

  1. (talking about running HQPlayer without Roon) I can get music folders into HQPlayer Library, but that won’t play.
  2. (talking about running HQPlayer with Roon) Roon doesn’t seem to notice whether or not I have HQPlayer Desktop app opened or not. Just gives same message that Roon cannot connect to HQPlayer.

As long as selected audio output device is not accessible, HQPlayer won’t let Roon to connect and refuses to take any dropped content.

  1. Make sure your DAC is not selected as default audio output device for Windows
  2. Make sure you don’t have any other applications running at configured to use that device (such as Roon)
  3. Select your DAC in HQPlayer device selection, not “Default endpoint”

Okay. In the attempt to test HQPlayer alone, I was not able to drag and drop a flac file from Windows File Explorer, it just didn’t appear in the area that Jussi pointed out when I dropped. I could do a scan from HQP library and get a folder of flac files, but then I couldn’t play it. So much for the HQPlayer alone test.
Trying to control HQPlayer from Roon, with no Roon Zone enabled except HQPlayer, using my host’s local IP4 address instead of local host, since some have not been able to use the latter, but no one has said they had a problem with the former, and the HQ icon selected on both my Windows 10 host and my Android tablet, I try to play a file either from the host or the tablet, and I get the same message, Roon cannot connect to HQPlayer. Weird, I would have thought it was because HQPlayer cannot connect to PS Audio DAC, because neither it nor any other DAC appears in the HQP Device box. Does HQP just look for a DAC connected by USB to the host and then fill that in the HQP Device box? If so, I am screwed because my PS Audio Perfect Wave II DAC is connected to the host by Ethernet, into the PS Audio Bridge II inside the DAC.
What next? I’m out of ideas. I’m less upset that I’m out $260 if I can’t get it to work, than I don’t have the opportunity to use it, since I know how critical the filter settings are on the DAC chip (even though Paul McGowan says he can’t hear the difference between the 5 settings).
C’est la vie.