Going for Roon - advise needed

:joy: but makes sense, I’ve lost my whole library during a headcrash; this was even better, because most tracks haven’t been ripped by myself… :thinking:

1 Like

Strangely it does to me too :grin:


Oh so this means I can’t use a Synology as my Library? Or is there a workaround?

Right now I’m doing my backups to Dropbox, but thinking of going on a USB stick on the NUC.


Update here. Yesterday the ssd arrived and everything worked seamlessly! Running my library on the internal ssd and very happy about it!

Thanks for the help and advise!


Luis yes you can use your Synology for library and backups without issue
Stresses the network a bit more is all.
If you’re network is up to it then no problem at all


Hi @Michael_Harris thank you for that information! Can you give me some connection tips? Because No matter what I do it always says there’s a path error there

Luis what error are you getting?
Can’t play music error or breaking up music problems.

I can try and help you but I am just a user like you.

Screen shots might help


Hi Michael. I appreciate any help! The problem is from the start when I even try to connect Roon to my Synology. Here’s a screenshot.

Luis try taking the smb:// out as that is a Mac thing, from memory i used to just put
\192.168.1.X\Music in mine
To keep things safer I had a read only user set up for reading music, with no access to anything else.
I will see if I can add it again for test purposes and get back to you

EDIT OK that worked \\Music
and popped up the library instantly to choose

I then get this where I can select the folder

I hope this helps

He is using a Mac (note the three dots upper left).
Try using smb://your_nas_name/volume_name
Don’t use the next level down folder path. Roon will let you select that once you’ve gotten the storage device info entered.

Hi @Michael_Harris and @grossmsj yeah I tried both your suggestions but the result is the same and the error keeps showing.

Ah. Try this:
smb://your_nas_name/Volumio (leaving out volume1)

Also some information about NAS settings here


I thought you were setting up on a Synology?
If you are using a Mac you will first need to share the folder.
From memory apple no longer support’s SMB:// but uses CIFS:// instead but that is the default so should not need to be added.

Luis can you confirm that you can see the share on your Mac

@grossmsj it worked! Thank you for the help, sometimes the solution for things are so simple…

What did you end up using for the path?
You are installing this network drive to your NUC running ROCK, correct?

Hi @Michael_Harris So I have my core on a NUC but am using a MAC as a remote to do the connection. I never had any problem seeing the NAS on Mac’s finder, so that was never an issue. So it was more simple to solve then I thought… With Volumio I had the folder set with the proper permissions but in there I need to use the /volume1 path. Roon is simpler, I guess

So I used smb://IP address/Volumio. I dropped the volume1 of the NAS.
Yes, the core is in a NUC, my Mac is just for the interface

I’m pretty sure \\IP Address\Volumio would work too. You might actually try this.
As @Michael_Harris said, the smb is a thing for Macs, if you were installing Roon on your Mac. But you are running Roon on a NUC, so the proper address should not have smb. (I misunderstood there).
If it works, that fine. But it could cause problems later.

edit: Just for completeness i use \\synologyserver\netbackup as my path for network backup to my Synology.

Tried without the smb and also worked, so if there a later risk of problems, better without the smb.
It’s good to know how to connect for future usage.

Btw not for me or for any of you, but if someone us reading I think before doing this on your Synology you must give NFS permission to the IP of your Roon Core. I think that without it Synology won’t allow a connection. If I’m wrong, sorry about that, but I had previously made this permissions on the folder.

1 Like