Setting Up Roon Back Up to Synology NAS

Core Machine (Operating system/System info/Roon build number)

iMac Retina 4k / Mojave 10.14.6 / Build 416 (stable) 64 bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

iMac core > WiFi > Virgin Media Hub > Ethernet > Netgear Managed Switch GS908E > Ethernet > Synology DS218j

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

IQ Audio Digi+ (Ethernet connectiont to Virgin Hub)

Description Of Issue

Just purchased the Synology DS218j to act as a NAS back up for the content on my iMac

As such, I have already successfully set it up as the destination drive for Time Machine, and also want to use it as the destination for Roon Backup.

I’ve set up a shared folder on the NAS called RoonBackUp, assigned read/write permissions to admin and my own user, enabled the SMB3 but I every time I try and get Roon to ‘find’ the destination I get error messages. This one if I don’t include user name / password

This one if I do include user name / password

I guess it could be any one of a million possible variables of settings and permissions within either Roon, MacOS or the Synology software, and I have hit the limit of my modicum of IT knowledge, so sending this in the hope that someone else has this set up and has either resolved this issue or successfully completed the set up :pray:

think it should be

as per link below. I don’t use a Mac so searched for the problem on the forum.

Hi @Matt_Clark,

I would suggest taking a look over our NAS Troubleshooting Documentation for additional suggestions, but I would suggest that you try IP Address instead of hostname to see if that helps.

You will also want to make sure that your Minimum and Maximum SMB versions are configured correctly as per the doc and screenshot in the thread and that “Windows network discovery” is turned on:

Also, see this following thread for some more useful troubleshooting info: Cannot connect to Synology NAS DS 1517+

Hope this helps!

Try \SynologyNAS.local/RoonBackUp

You don’t use smb:// prefix like on Macs. And you don’t specify the /volume1 part of the path. You only specify the SMB share name.

Also, very strongly recommend you make a dedicated “Roon” user and assign them read/write to only the RoonBackUp share you created. If you are importing music from music shares, then give the Roon user read-only access to the imports.

Thank you, that worked! In the other thread it mentions adding just the folder name (eg RoonBackup) after the smb:\ location.

I had copied that folder location out of the Synology DSM, which came with the \volume bit in the string which wasn’t needed. Simplifying it down to smb:\NASNAME\Sharedfoldername worked.

First back up ran successfully so looks like I’m sorted.


Yes, you were right about not needing the \volume1 bit, simplifying it to just the folder name did the trick! Thanks

Hi @Matt_Clark,

Glad to hear you got this sorted out, hope you have a great continued Roon experience!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.