Going insane trying to install ROCK codec

Three hours ago, this topic was closed. Goodness knows why, 'cuz clearly there is still a problem.

I’ve got a newly installed ROCK, less the addition of the codecs. No need to point me to the KB page for how to install. Naturally have done all that. I’m using Ubuntu, and have a clear SMB connection to the /Data share with its /Codecs folder. In that folder is a 78.0 Mb file called “ffmpeg”. So it appears it’s been fully uncompressed, and in the right place. And, or course, I’ve rebooted the ROCK more times than I wish to count.

I’ve tried to get the same file in Windows, downloading from the places mentioned in the KB, but when trying to establish an SMB connection to the ROCk’s /Data share in Windows, I’m confronted with UID/pwd requirements. Huh?

Pulling my hair out. Any help would be MOST appreciated.



Did you try to connect to a share being:
\\ROCK ?
As in - without /Data. Then just navigate there.

Thanks for the help. But navigating - and getting a legit connection to - the appropriate place on the ROCK NUC is not remotely the problem.

Here’s a pic of the share, with the Codec folder, with the appropriate sized file in the folder. Something else is wrong, like Linux permissions, or something.

Thanks though.

PS - It’s hitting my bed time, so replies future replies may be a bit delayed. :wink:

Weird, my ffmpeg is about 47 MB in size. Last time I checked there seemed to be a couple of different ones, did you get the right one?

Good point. Thanks Daniel. I started with that one. Here’s a pic. Not in the same place, but the point is that I have one about the same size, and tried it. Obviously did not work.

When I download this link from the KB, I get this file at the top. Compressed.

Uncompressed you can see in the window, which has another file that should be extracted. Two extractions required, right? The second extraction yields what you see in the following window, a 78MB file.

So if anyone has a link to the correct file, that they can share, I’d be MUCH obliged.

Thanks. :slight_smile:

I’ll do some search fu in the forums, but, I seem to remember an issue with the decompression and permissions setting of the ffmpeg file when copied from a Linux install.

Daniel - Thanks, I remembered the same thing, which is why I tried the Windows route, but was stymied when the SMB connection from Windows required a UID/pwd combo. As mentioned in my OP.

That is weird. Is SMB 1.0 enabled on the Windows box?

SMB v1 is actually not needed. What’s needed though is to allow “insecure guest logons”. Yes it is insecure – but at least less insecure as enabling SMB v1 is.
If your Windows doesn’t come with the Group Policy Editor (if you don’t have the Pro or Enterprise OS variant) you can use the Registry Editor to set/change the value (and add the Key first if needed) directly in the registry. Properly done, you should no longer see a UID/PWD dialog when connecting to the share.

Out of curiosity: Did you try to enter a user / password combination, something like for example “Anonymous / password”, and go along? Is the connection refused or does it connect?

1 Like

@Rugby Yes, SMB 1.0 is enabled on the Windows machine. But I had to go into Control Panel/Programs/Turn Windows Features On or Off/SMB 1.0 to check the check box necessary for it to work. Then reboot.

It worked! Thanks for the great tip @BlackJack. But I did not need to dip into the Registry. But your last question helped.

Previously I tried to supply blanks for the SMB UID/pwd, and it didn’t’ work. Also “anonymous”. But due to your question, I gave “Anonymous” a shot, and it took me straight to the \Data share. Specifically…

When I looked in Window 10 File Explorer under networks, it did not see my ROCK. But in Command I pinged ROCK’s IP address, went back to File Explorer, and then it saw it as a computer under Network. Then double clicking the ROCK icon brought pulled up the UID/pwd dialogue box that I previously had not been able to get past. This time I entered “Anonymous” for the UID, no password, and it took me straight to the data share!

FWIW I could do all this in Ubuntu, much simpler. But the file that I was putting in the Codes folder was not working. So I was going the Windows route. Anyway…

Using the URL provided in the Roon KB, I downloaded the Tar’d file, and then used 7-Zip in Windows to unpack it. Twice. NB - I had to get 7-Zip from the Windows store. Free. Then it was a simple matter of copying the ffmpeg file (no extension), and pasting it into ROCK’s /Data/Codecs folder. FWIW the file size showed as 76,183 in File Explorer.

And ROCK saw it immediately. Did not even need to be rebooted.

All’s well that ends well! :slight_smile:

Thanks for the help folks.