Google Chrome Display not working

Core Machine (Operating system/System info/Roon build number)

Windows Server 2016 latest patches
Roon Core 1.6 build 416 stable 64 bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Too many to list, I’m an IT Engineer and have TONS of network equipment, AP’s, router, gateways, VLANs, etc…

But Roon is working and displaying perfectly to all of my Sonos, Chromecasts, etc…

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Lots of Sonos in all rooms in and outside: Play:1’s, Play:3’s, Play:5’s, SUB’s, Playbar’s, Chromecasts.
All wireless.

Description Of Issue

I copied the display link from roon and entered it in a new tab in the latest version of Google Chrome on my Mac Book Pro (10.5.1 Catalina). It pulls up a screen that just shows “Roon” in large bold font, but nothing else. I have NO firewalls enabled internally on my network. mDNS works perfectly from my pfSense router, and I have no issue with other apps / hardware that use mDns or Bonjour.

Thank you!

Hi @Anthony_Reinking,

Can you share a screenshot of the Displays settings screen as well as a screenshot off as well as a screenshot of the Zone Display settings (seen below)?



Hi @Anthony_Reinking,

Have you made sure to start the display in the Display menu? After navigating to the IP, you will need to turn this feature on in your Core.

Also, do other web browsers have the same behavior? Can you check to see if Firefox/Safari display the same issue? What about other PCs on the network, do these behave the same?

Yes Windows, Mac, Linux, Chrome, Firefox, and Safari all do the same. Even on the same computer as core is running.

Chrome doesn’t show up in the display menu…that is the problem.

Hi @Anthony_Reinking,

Thanks for confirming.

We have sometimes seen “teredo tunneling pseudo interface” cause Roon issues on Server 2016, as mentioned in our Networking Best Practices:

Windows Server 2106

Windows Server 2016 by default has a “teredo tunneling pseudo interface” that can cause issues with Roon Remote connections. It is suggested that this interface be disabled if not in use by going to device manager -> view -> “show hidden devices” and disabling it under the Network Adapters section.

If you try disabling this feature, does that trigger any change in behavior?

Can you confirm if you have any firewalls which could be blocking Roon? Have you made sure to add both Roon.exe and RAATServer.exe as exceptions? These .exes can be found in the Database Location/Application folder path, and I would set the exceptions on the application level.

I have the same issue, my roon server can run on a windows 10 or a mac mini. Both display the word “Roon” in big font and a ‘?’ at the top right corner of the web page.

I even try “http://localhost:9100/display” on the same machine where I am running Roon and it shows the same thing.

Clicking on the question mark will point you to Have you performed Step 2 or is your browser also not shown in the list of displays?

As said by myself, and the OP: the URL only shows the word “Roon” in the middle of the page and the ? on the top right corner of the page. The step (2) only shows correctly if the URL works, in this case it does not, there is nothing to do in step (2).

This is perfectly fine but there’s nothing else to see here until you successfully perform Step 2 to connect the display to a zone in Roon.

As QuinnT and I both stated Chrome Browser is not in that drop down…so we CAN’T enable it.
As well, I mentioned in my first post; I do not have ANY internal firewalls enabled on my network.
Teredo is already disabled.

Like this? grafik No question mark?
Then JavaScript is blocked.

You maybe running a blocking web-proxy?

I can repeat this behavior when I block XMLHttpRequest (XHR for short). You’re maybe running a browser extension that blocks XHR?

I disabled all extensions in Chrome, unfortunately it does the same in Firefox, and Safari; and I don’t have any extensions in those browsers. I do have a question mark, but it just takes me to instructions on how to enable the Chrome display.

Hi @Anthony_Reinking,

I would like to completely remove the windows server from the equation. Do you have a standard Windows 7/10 or Mac PC which can temporarily host the Roon Core and if so can you verify if the behavior is the same there ? I am wondering if this issue is due to the OS or perhaps the network and this test would help us clarify.

I will try the core on my Macbook…

Interestingly enough it worked fine on the Macbook, so I switched the core back to my Windows 2016 server, and Chrome starting working on that? Weird. I haven’t touched a thing other than switching the core back and forth.

You can close the ticket

1 Like

Hi @Anthony_Reinking,

Glad to hear that both the Macbook and Windows 2016 are now working with the displays!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.