Google Nest Hubs no longer showing

Roon Core Machine

Mac Mini M1 8GB, running Monterey 12.0.1

Networking Gear & Setup Details

Google Nest Wifi, Draytek Vigor modem

Connected Audio Devices

Sonos Amp (ethernet), Sonos One (Sonos Net), Sonos Roam wifi, Nest Min Speaker, Nest Hub Displays (x3) wifi connected.

Number of Tracks in Library

25351 tracks

Description of Issue

I’ve always been able to cast to Google Nest Hubs from Roon and even use them as a display (although this has never worked particularly well), however I noticed this week that none of my Google Nest Hubs are listed in the available devices or on the Audio tab of Settings.

I have tried restarting Roon and restarting the Google Nest Hubs, but this hasn’t worked. Not sure if this is a known issue or if there is a setting or workaround that I’m missing.

Hey @Duncan_Heavisides,

I am so sorry we have taken this long to get back to you :pleading_face:

I wonder, has anything changed since you posted about this? Could you please check if by any chance the OS update has enabled a firewall? Could you please disable it?

Thanks a lot :pray:

Hi Rebeka, thanks for the reply.

It was the Mac Firewall, it must have altered the settings when I installed Monterey. I’ve now allowed Roon connections and all the Nest Hubs are once again available for streaming. It’s odd as some Google devices like speakers and Chromecast with Google TV were still visible, even with the firewall on.

But all sorted, thanks for the help.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.