Graphics & Waveform issues

Core Machine (Operating system/System info/Roon build number)
Roon Version 1.7 (Build 710) Core.
Intel® Core™ i5-8400T CPU @ 1.70GHz
Intel® UHD Graphics 630
Realtek High Definition Audio
Intel® Display-Audio
USB Audio Device
Samsung MZVLB512HBJQ-000L7

QNAP TR-002 DISK00 USB Device
QNAP TR-002 DISK01 USB Device
Samsung SSD 860 EVO 2TB

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Intel® Ethernet Connection (7) I219-V
Intel® Dual Band Wireless-AC 8265
Intel® Wireless Bluetooth®

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
I have recently moved to Windows 10 and transferred Roon there as my Core. I am noticing some bugs on Windows 10 that didn’t exist on my ten year old Thinkpad running Windows 7.

I have about 12TB of music, a total of 72095 tracks - all in either FLAC, WAV, or DSD format. They all have album art. It took about 3 days, but Roon has now carried out a background audio analysis on this data. Despite having a far more modern system with much greater resources than my previous Thinkpad, I’ve noticed two key issues:

  1. I am experiencing the bug where characters are occasionally missing - individual letters, numbers, etc. I have inquired about this and evidently it’s a known issue. Since then, I’ve reinstalled Roon, updated my graphics drivers, but the problem persists. It’s an annoying issue that gives Roon a sort of “broken” appearance.

  2. It seems that as soon as this issue occurs, another one follows: the waveforms get “stuck” - i.e., whatever the last successful waveform was, it will then repeat itself on the next track irrespective of what that track is.

I’ve also noticed that Roon can use anywhere between 4GB to 9GB of system memory.

These problems are new to me and never occurred on Windows 7. I would very much appreciate a fix, because it somewhat tarnishes the experience.

Thank you in advance.

Did you get latest GPU driver from the Intel site (rather than Windows update)?

Both. I tried with the Lenovo drivers and from today the generic drivers from Intel. None seem to make any difference, though both work as normal otherwise.

Hi @Dylan_Trigg,

Do you have any screen overlay software running like MSI Afterburner?

I wouldn’t have installed it myself. This is a fresh vanilla install of Windows 10, so I doubt it but I’ll double check.

I double checked this; the problem(s) remain. I also rescanned my data, but the problem persists. I would be tempted to re-analyse the whole lot, just in case the original audio analysis was somehow corrupted the first time around.

Any more suggestions would be welcome.

Hi @Dylan_Trigg,

Can you please share a few screenshots of these issues?

By all means, in the following screenshots you’ll see:

  1. Missing letters (“H” in Hearts).
  2. The same waveform repeated despite playing a different track.
  3. Indication of RAM usage.


1 Like

Any update on this? If you need me to send my logs, I’m happy to do so. Thanks.

Hi @Dylan_Trigg,

Thank you for the screenshots and for your patience while your case reached my queue again!

Yes, logs may be useful here, can you please use these instructions to access them and send me a set?

Have you tried a fresh database on this Core? After sending logs, can you please use these instructions to set your current database aside and verify if a fresh database and a small portion of your library have the same behavior? This should give us a good data point to work with.

Thank you and Happy Holidays!

Hi there,

Thanks for looking into this. I will send my Logs to you in a RAR folder in a moment.

I have just tried a fresh database re-installation - removing all 12TB of music and replacing it with a fresh and cleared install of just one folder, “Heavy Metal,” which weighs in at 1.27TB. I should also add, I organise all my library in 3 main categories: A To H; H To P; P To V. Inside those main folders are a series of genre folders.

In any case, I tried this and yes, the problem still persists:

Any feedback would be welcome.

1 Like

Hi @Dylan_Trigg,

Hope you have a great New Year and thank you for trying the fresh database! This confirms that the issue is not database-related but possibly hardware. Your logs are currently with our QA team for review, once I have the team’s take on it, I’ll reach out again. Thanks!

Hi @Dylan_Trigg,

Can you please confirm - does this issue only occur on the “Now Playing” screen or do you see this behavior occurring elsewhere in Roon too?

Thanks for the reply; it occurs on screens within Roon and not only “Now Playing.” Thanks.

1 Like

Hi @Dylan_Trigg,

Can I please ask you to share a screenshot of this issue occurring in other areas of the Roon app?

Hi, thank you. I have now upgraded my machine from a ThinkCentre M720Q to a ThinkStation P340 Tiny, the latter comes with a dedicated GPU (NVIDIA Quadro P620), so the previous problem has been resolved (although I will never get the heart of what caused it in the M720Q, because even when using the optional integrated GPU on the P340, the issue is not there).

1 Like

Hi @Dylan_Trigg,

Thanks for letting us know that the upgraded Core does not have this issue!

If you have any further issues or questions please let us know!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.