Grouping speakers to play the same content [glitches when doing so]

Here is the issue I have, I have Roon feeding a Bartok upstairs. Downstairs I have BlueSound Nodes. Roon works on both though I cannot group them to play the same content.

Screen Shots.
Appreciate any help.

Not sure what a Private Zone is or how to set that up?

Welcome to the Roon community, @todd_radwell.

You can group zones that share the same protocol. Therefore, you shouldn’t have an issue grouping Bluesound devices and the Bartok since these all use RAAT.

However, you can’t combine RAAT and Airplay devices.

If all your devices support RAAT, double check Roon Settings > Audio to make sure you have enabled the correct interface for each device.


For your question about Private zones, if the zone is set to private it cannot be grouped.
Go to the device setup and look to see if “private zone” is turned on for each of the zones.

You can access the device setup by either right clicking the zone from the zones icon:

Or going to “settings/audio” and clicking the gear icon next tot he zone:


Thank you, so simple and it worked.
What confused me was the Private and not understanding that. I did need to match by the routing number once I disabled AirPlay and Enabled the option closer to the top of the web page, the name I had used for AirPlay restored and after a few seconds it was playing.

Works great, the Studio is a high end 2 channel system with Wilson XVX speakers, this is upstairs, volume is fixed to Roon, controlled by a VTL preamp.

Downstairs is a shop with in walls.

The whole building now rocks.

Here is a picture of the 2 channel setup.

1 Like

So update to the saga, I am using a DCS DAC first the Bartok and I was getting MQA glitches in playback, suspecting an issue with the Bartok the dealer offered me to upgrade to the Rossini Apex DAC as part of resolving the issue. He brought his DAC over to my studio space and we did an AB comparison on my system, no glitches on MQA and the sound was a little more dynamic though both DACs are outstanding for my preferences which lean warm. We thought we solved the issue. Once I had my new Rossini I regrouped the downstairs speakers and the glitches were back.

The culprit now appears to be the grouping perhaps something to do with the software attempting to synchronize the two zones.

Has anyone ever had this issue and by some chance is there a fix?

If I ungroup and just listen to the two channel system upstairs MQA playback is fine, and even when I do group the two systems the downstairs Bluesound Nodes and NAD 4 channel amp have no glitches they only happen upstairs.

Any help would be greatly appreciated.

Is everything on wired Ethernet? Sounds like a possible network issue. What happens if you play simultaneously to both zones but not grouped?

Yes everything wired.
No glitches unless grouped.

Hi @todd_radwell,

Thank you for the report. Are you able to provide us with an approximate timestamp, or an example track title of what was playing, when you most recently experienced this?

It sounds like you’re hearing clock drift between your synced endpoints.

The team will follow up and investigate diagnostics from your account that reach our server. We should gain some insight into the cause of what you’re experiencing.

In the meantime, please verify that you’ve updated firmware across all of your endpoints (in particular, BlueSound).

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.