Guidance with setting up R.Pi as endpoint with specific extensions

Firstly I’m at the edge of my knowledge here and whilst I will get there I want to be sure I can achieve what I want before diving in!

I have just repurposed my Windows NUC as a ROCK (very impressed with the product and ease of installation and the KB, thanks all involved)

In now need a way of running extensions that can be left permanently on.
I will likely get an Raspberry Pi of some type (advice gratefully accepted).

Ideal requirements:
Digital endpoint for Roon with appropriate software
Capable of running extensions, incl. the manager and repository
Specific use of the Meridian RS232/ip volume control extension which I have read needs Docker to run as an extension on a Pi (not sure what this means!)

This is where my knowledge runs out…

Can I achieve the above on one Rpi and if so how complex or not would it be.

Thanks in advance for any help/advice

Hi @Hectorson, this can almost certainly be achieved with a Pi and it might be more straightforward than I initially feared. I believe that this is the extension you want to run:

It’s not clear that Docker is required, do you have the reference that made you think so, please?

IF it doesn’t need Docker then installing DietPi and the extension manager should do the trick. It may be a little taxing if your tech skills aren’t strong but with a bit of patience and assistance you’ll get there. Feel free to ask here and I’ll do my best to help.

1 Like

Thanks for the response

This is the link to the bit about docker.

Good news that it may be possible!

That looks definitive, thanks. Still shouldn’t be a problem and the link is to the extension manager that’s bundled with DietPi so it should still work. You’ll need to set up DietPi and the extension manager first. You can ignore the section on “Roon Web Controller Client”. Next add Docker to DietPi and then finally use the extension manager to get the Meridian control.

Good luck and don’t stay stuck.

Thanks again, I’ll get ordering.

One more question as I can’t find an answer by searching the forum, how much memory to get on the Pi?

There never used to be a choice, any size you wanted as long as it was 1GB (and less on early models). The playing part doesn’t need much, the extensions and manager may take a little more. The basic model 4 is 2GB and there are 4/8 versions as well right? 2GB should be enough but I’m prone to overkill and might go 4GB if funds weren’t a big bother, then you know. Even with my attitude 8GB is real overkill IMHO.

1 Like

Matt for most of my streaming endpoints I go with 2GB.
I only choose more memory for the Pi that runs Roon extensions and DNS server etc.

Still 4GB plenty for that a d probably 2gb fine as well.




Thanks to @killdozer and @Michael_Harris, I have a Pi with all the software I intended installed - I’ve not fully tested everything but I’m on my way!

Next step is to select a HAT with a coax SPDIF output. I’ve done a bit of reading but any input from forum members about the relative quality appreciated. I’m feeding an old pair of Meridian DSP33 speakers so 96/24 highest sample rate required.

Thanks in advance

1 Like

Hi Matt great to hear that you are up and running.
In terms of Hat’s my only experience is with HifiBerry board’s and not sure how they will work with your system but they have been great for me. They are low cost and good quality and will happily drive 24/96 across both toslink and SPDIF.

Allo also make some great board’s with good reviews but are generally more expensive, though might match better with your Meridian system.


I had looked at the HifiBerry boards and think this is where I’ll go.


So I’m installed with DietPi, Extension Manager and Meridian Volume Control. I have connected the serial adapter to the Pi and this is recognised.

root@DietPi:~# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I cant seem to get the COM port setting right in the Meridian extension and whilst I realise this is getting niche I’d be grateful of any support to get this working.


Matt I have just had my hifberry metal cases delivered today so I will be putting the Pis in them later.
They should hopefully work well, you can also try the os they make which is nice, but you would lose the extension manager etc.
I like DietPi and have my extension manager and a Roon Bridge running on that.

I can’t offer you any help with Meridian kit though sorry as I have never even seen one.
I am sure there will be people here that do have some experience.


When you install the Meridian extension you have, underneath the Action dropdown, the Docker Install Options, if you select this then you can specify the Serial Device Path. The path you should enter is:


The numbers are the numbers you see in the output of the lsusb command. After installation you also have to set the serial port in the Settings of the Meridian extension itself.

1 Like

Hi Jan,

Thanks for your advice on this. I had missed the install setting completely.

I now get this in the extension manager settings:

STOPPED: tagarm32v6

Not sure where to go now…

EDIT: all working fine and I can’t type!


When I said all working…!

I have one final issue that I would appreciate any support with.

It all seems to work except it doesn’t control the volume.

So trouble shooting so far:
I have tested the serial converter and all other settings by downloading the Meridian extension from github to a windows PC and running using node.js.

Using the path Jan provided in both the docker installation setting and in the meridian extension settings I can get the extension running and the volume control works visually in Roon but doesn’t communicate with speaker.

So I think the only variable is the RPi environment but here I’m stumped!


The path I provided might be wrong, the serial device probably appears as /dev/ttyUSB0, check on the DietPi console if this file exists and give that a try during installation. Check existence with:

ls -l /dev/ttyUSB0

There should be one file found.

Got it, I had to reboot between uninstalling and reinstalling the M Extension and the path you supplied worked. Without a reboot the extension starts and fails.

I had tried that path in the M extension yesterday but missed the Docker settings in the installer. Thanks again for the support Jan.

1 Like