H390 and H590 now Roon ready!

A long wait but looks like Hegel delivered the goods at last.
Now let’s get some runtime on it.


Fixed it. Yes, requires Factor Reset (took me two attempts) and to ensure that no Max volume limit is set. That’s the variable that messes with the volume output. You can still set a default volume for powering on the unit.

Very relieved!!!

1 Like

I have a feeling that a max volume setting may be the reason behind the reported volume issues.

The volume handling has changed with this update.


I did a factory reset for my H390 and then chose a new start-up volume, which worked great.
What did not work, was programming a new max volume (for the amp as a whole, not within Roon). The manual says that I have to set a volume level first and then press these buttons on the remote simultaneously: DAC+ and VOL+.
When I do this, the amp immediately sets its volume to 100/damped, coming from 50. Luckily, there was no music playing and I had switched the amp to an unused input.
Also, when I chose Roon again as a source and brought the volume down again, no music could be heard after pressing play. I had to do a second factory reset to get sound again.
Is this expected behaviour?

Congrats Hegel! Sound quality is spectacular. Patience is its own reward.


Thank you Hegel! Worked for me 1st time, and sound quality on FLAC seems improved over BlueSound feed to Hegel. (H390 / KEF Reference 1).


No problems with the update, all is well. Thanks Team Hegel!

1 Like

Update of my H390 went smoothly, but still waiting for code for the 60-day free Roon trial!

Important note on the Roon firmware update for H120, H190, H390 and H590!

The max volume and start volume features have been changed. The volume scale will now always go from 0-100, if you previously had a max volume at for example 70, the scale would now go to 100 which will be the same volume as 70 previously. So, if you used to listen to a particular volume level before, you will have to turn up to a higher number with the new firmware if you are using max volume.

You will see the text “Damped” below in the display when you turn on a Roon updated amp with a max volume level setting.

Please see the updated user manual for your model for details: https://support.hegel.com/

Resolution Digital Inputs	 
Resolution USB	32/384 + MQA + DSD256(DoP)
Resolution network/UPnP	24/192 + MQA + DSD64(DoP)

as I get - my DSD128 which I formerly play thru usb - now resampled into DSD64? all network formats incl. ROON is 24/192 + dsd64?

I noticed the same last night with my H590. DSD64 was the maximum I could get using Network/Roon.


Resolution Digital Inputs
Resolution Coax 24/192 + MQA + DSD64(DoP)
Resolution Optical 24/96 + MQA + DSD64(DoP)
Resolution USB 32/384 + MQA + DSD256(DoP)
Resolution network/UPnP 24/192 + MQA + DSD64(DoP)


Resolution Digital Inputs**
Resolution Coax 24/192
Resolution Optical 24/96
Resolution USB 32/384 + MQA + DSD256(DoP)
Resolution network/UPnP 24/192

** On products produced after August 2020 and containing the letter “E”
in the serial number, the H590 supports MQA on all digital inputs
and supports DSD(DoP) on all digital inputs except optical.

Source: Product Comparison Chart

1 Like

Got the 60 day free trial code this morning from the man himself. Thanks Anders!

Everything works perfectly!


Can’t believe it really - been over a year since I bought my H390.
Did the update - added the Hegel to Roon devices and seems to be working well.

1 Like

I didn’t get asked to make this but was just experimenting with it yesterday on my own H390……so I decided to make it into a short video, on set up, volume control and the DAC loop feature. Apparently you get a 60 day free trial for Hegel owners which sounds pretty decent.


Nice work Simon, I’m sure users will find it useful
Might be worth putting it in it’s own thread so people find it at the top of a post

1 Like

Thanks Michael , I posted to the Hegel fb forum
So it’s probably out there already but thought I’d post in here seeing this is Roon

1 Like

Can Roon control the volume, or should you set Roon to 100% and use the Hegel remote?

Both (Roon / Hegel remote) are linked. So you can use both.